Android: Mapillary 6.0 open testing


Hi there. Our new Open Testing (version 6.0) is out. Thanks everyone for participation (How to join? , Don’t have the app? ).

We’ve updated the look and feel of the application with under the hood performance updates to get a smoother feeling when navigating the app. While the new design was already available in open testing to collect your feedback (link), we worked to further improve it.


  • Introduced homepage screen with all your captures available on it
  • Introduced Upload dialog to the homepage to enable users uploading all captures or just navigate to view them
  • Introduced labels to captures to indicate in which state they are and also when clicking on failed uploads it displays the reason for failure
  • Introducing Dark Mode
  • Introduced autofill and integration with password manager for login
  • Added dash support to the user name
  • Added filter coloring by age to the map in camera
  • Fixed filter coloring by age to not display old (red&yellow) sequences over the new ones (green)

If you have any questions, or suggestions - please report them here.

cc: @Yaro @boris

Best Regards,


Version: 2024.02.02-6.0.181 @ Android 11

When I first went into the details of the sequence, the delete, rotate and share buttons did not work at all. It was the same when I tested selecting multiple shots and deleting in bulk. Suddenly, when I went to the view of all sequences, I noticed that the photo of the sequence had changed, and when I went into details again, the buttons were working, but terribly slowly. Painfully slow.

Also, how do I delete an entire sequence at once? In the previous version it was enough to move it to the left, now it doesn’t work, and there is no button anywhere to delete the entire sequence.

Hi @GanderPL I think one of the Open Testing versions had this problem, and it was fixed in the latest update. Let us know if you have any problems with delete/rotate/share in 6.0.181. That might be that different devices behaves differently, so I would also ask you to include the details of your device.

Deleting the entire sequence is missing, right. One must select all images and delete all of them to delete the entire sequence. Deleting the entire sequence was expected is not very helpful. We might add functionality to next release, it’s tbd. One question, is in which cases do you usually delete the entire sequence?

I should have been starting with this. Thank you for your feedback :slight_smile:

BR, Yaro

Yes, I forgot about this important information, which is the application version. I have already updated my post with this information. The issues described concern version 2024.02.02-6.0.181

1 Like

This includes places too close to my coordinates being excluded, or coming from a route that already has a lot of current traces, when weather conditions make the sequence difficult to read, or for any other reason the entire sequence is unwanted. I use this option very often and not having it would stop me from installing the latest version, and if the older version could no longer be used, it would greatly limit my use of it. I can’t imagine having to delete sequences by selecting all 300 of it photos one by one. Someone is really such a sadist, because I am not a masochist.

1 Like

Roger that. We’re working on this feature already. ETA - ASAP (which is like a day or two).



Version: 2024.02.02-6.0.181 @ Android 11

My + Historical not work propertly.

1 Like

@GanderPL thank you for reporting it. We’ll try to address this issue as soon as possible.

Version: 2024.02.02-6.0.181 @ Android 11

When I select all the photos from the sequence (here with 3 pieces) and delete them, I return to the view of all the sequences, the application hangs, and then after a while the application crashes

1 Like

We’re working on all of them in order to include everything in the update.

BR, Yaro

Android 13, When viewing the map with the timeline function enabled, the app shuts down when I select one of the available photos. App version 2024.02.02-6.0.181. It’s not every time, but happen three times on six attempts.

@GanderPL 6.1.11 is live in Open Testing (stuck in approving since Friday). There you can find sequence delete with swipe, fix for the filters and a crash after a click on the map.

PS @inwazjamb the mentioned crash must be fixed in 6.1.11


1 Like

First noticed: Version: 2024.02.02-6.0.181 @ Android 11
Still present: Version: 2024.02.09-6.1.11 @ Android 11

I noticed one bug: when I open a waiting to send sequence and click on a specific photo of the sequence, and the application goes to the preview of this shot with a map, opens the first photo of this sequence, not the clicked one.

Yep, it’s here now! And working! :+1:

Version: Every one I’ve used, 5 and 6, but this could be fixed eventually.


  1. Only the most recently added exclusion area is visible (all should be visible).
  2. Only visible while recording a sequence (should also appear when browsing the map).
  3. Very limited address database (no addresses available, although they exist, e.g. in OSM).
  4. Does not allow you to select a point without an address (not all places have an address if it is already in the database).

Privacy is very important these days, and I don’t want to have to remember to turn sequence recording on and off when I’m in certain areas. Since there is a filter for this, it should provide minimal functionality (I don’t expect to be able to draw exclusions as polygons, although that would be the most convenient way to set up excluded areas). I believe that points 1-2 should be very easy to correct, while points 3-4 should go to the decision-maker because I think they are important enough to at least be discussed.

@GanderPL yeah, I’ve faced with this issue with (the app opens first image instead of the selected one) yesterday and had to pinpoint the image on the map to prevent scrolling through 300 images. Annoying one, working on it.

And you’re correct with the complexity of the problems 1-4. We will discuss those to see what options do we have.

The point 1 is an error, it shouldn’t be like this. Checking what’s wrong. My guess they’re still there, just not visible on the map, due to the map optimisation, we have to disable it for some layers (like this one) as it’s on by default.

cc @boris


Thanks for letting us know @GanderPL

  1. On which screen are you seeing this? If I go to the blocked addresses screen I seem to see every one I’ve added (tested with 3)
  1. You are referring to the map you see on the camera screen, is that right?
  1. Do you have an example of an address which isn’t working for you? Out of curiosity, does it work on ? We use the HERE API for this I believe. Will also consider #4 here, depending on how this looks.

Yes, but these maps are too small to clearly indicate whether they cover the entire area I wanted to exclude (that’s why drawing the polygons would be useful). The first time I entered all the local addresses I knew, just to be sure.


One look at these maps and I wouldn’t trust them again. They’re more incorrect than Google Maps. What’s happening here is a nightmare.

1 Like

Got it, thank you for the clarifications. We have added these items to our backlog for future releases.


We just released a new version of the app 6.1.16 which has the fix for opening wrong photo when you click on it.

1 Like

I confirm installing version 2024.02.13-6.1.16. I will test the problem fix soon.

Yes, it works now. I confirm.