The app doesn't want to use SD card [Solved]

Hi, I know of a trick you can use. It’s a hassle though.

Install the opensource app Ghost Commander. You can find it in F-Droid, the opensource counterpart of googles Play Store, and (probably) also in PlayStore too.

Open the app and use SAF, Storage Access Framework. This mode allows you to access system-protected folders without having to root your phone. So you can access your SD card whether or not your phone allows it and you can access Mapillary’s storage too.
The first time you use SAF it needs you to pick the root folder to use, this can be either your internal storage or your SD card.

So, if you want to use a lot of disk space for Mapillary, you move the content of theMapillary data folder to one or more SD card(s).
At home you can reverse these actions to upload everything.
An alternative is to use the Mapillary web uploader on your computer.
So, not an easy hack but it does work.

2 Likes

Solved this issue, plz find my thread Uploading hangs.

I can not find a folder with Mapillary photos using Ghost Commander.
android//data/com.mapillary.app/files is empty and i have at least 14 photos to upload
rgds

That is the correct directory. It can exist on both the internal and the sd cards memory.
Something else which is a problem if you connect the phone to the windows computer, is the window’s way of connecting by 'devices and printers, it will only allow you to see unprotected folders. This should not be a problem in Ghost Commanders SAF mode.

I’d also like to see SD card storage enabled. From what I understand it was supported in the past, and I find the reasoning very flimsy. Not having access to memory cards makes Mapillary much less useful for me, given that my phone has limited storage.

1 Like

Here is a cynical answer.
I just learned that Mapillary is bought by Facebook, so don’t expect the devs to give a shit about what we users need.

It is the power of money that counts. The users, you and me do not matter.

We want to access to our work. We are not workers, we are users. Try to do the same to the other apps of Facebook : Facebook, app, WhatsApp, Instagram and say to the user “You are not allowed to access to your pics”.

4 Likes

Who make this change never uses mapillary
Impossible to work without SD CARD

For me, this means the end of my contribution to Mapillary
300 gb to upload and everithing with problem - upload with command doesn’t enter, android without SD CARD, desktop cut the sequences and upload in the midle east (i am in brazil)
Why? “improve”

3 Likes

It’s been over a month and still nothing… It’s really impossible to use the app without an SD card for me, because I’m using my spare phone. But apparently the devs don’t care…

1 Like

Whyyyy i can’t add Image???

U can set ON SD car in Mapillary APK settings.

As I’m impacted by this too, I mostly use a S7 for mapillary, which has essentially become unusable for the purpose, not to mention trying the same on my current daily driver, i gave this a closer look.

The issue the gizmodo report is about app specific flaws and irrelevant for the discussion at hand, see https://www.xda-developers.com/google-samsung-camera-app-exposed-video-intents-third-party-apps/ for more information.

What is true is that up to Android 10 the app specific directories on “external” devices (which includes the internal /sdcard mount point and removable storage, Android terms confusion reigns here) were accessible by all apps that had the read external storage permission. For most people I believe this would fall under “expected behaviour” and not a flaw as such. From Android 10 onwards the app specific directories are not accessible to other apps in general.

The app specific directories have the form Android/data// relative to the mount point. The mapillary app used to store the recorded images in one of these directories, if you set the option, to the one on removable storage. This allowed users to, on the one hand, access their images before upload, and on the other hand use cheap SD card storage for those phones that supported it.

The new mapillary app stores the images in the private app storage that was never accessible to other apps and, on non-rooted phones not accessible to the user directly at all.

Now mapillary does have a tiny privacy point in that prior to Android 10 a malicious app could have accessed the stored images, but that was by design and not a flaw as such. Why they suddenly decided that they need to protect us against this is unclear, but regardless they still could provide access to the images via an in-app export function even in this most restrictive scenario if they wanted to (this would only solve one of the two issues, but at least that).

On devices running Android 10 and later, there is no reason not to revert to the old behaviour as the access to the app specific directories has been massively reduced.

Simon

2 Likes
  1. If there is a google problem please publish the apk directly on mapillary site with the function to use sd card enabled and unprotected as before.
  2. I have a rooted phone but I’m unable to find the saved photos. Where I should search?

Wait, what? I just recorded miles of bicycle photos with what turns out to be an old app, and I’m being forced to upload them using the new app which can’t find them.

You are solving a problem that I don’t have, and you are creating a problem I didn’t have.

Stop it.

I captured these images using app 3.179, it won’t let me upload, and the new app 5.0.5 doesn’t find the images. How can I fix this?

1 Like

What happened to the dev team when Mapillary was bought, I can only guess.
I do not think they will get a share of the money.

If this would happen to me being a developer, I’d quit the same day.

For some reason, the photos are ultradeep hidden and if your rooted phone will help?
Maybe if you are a good Linux hacker.

Hi Russ. In the old app, you can still access them from your computer, and upload them from the computer using the Desktop Uploader. I know this is not optimal, but it’s a solution at least.

2 Likes

Thanks, but I’m not going to deal with your intentional breakage. I’m done with you. I don’t have to do this, it’s for fun. It’s not fun anymore.

Hi everyone,

Thanks for your all valuable feedback on bringing back SD card support in the Mapillary Android app. Mapillary Android app 5.1.0 supports saving images on SD card and transferring Mapillary captured images to the PC. Please let us know if you have further feedback on using SD card for your captures.

Happy Mapping :slight_smile:

5 Likes

Hi @asturksever
Thank you for the update.
Is feature to send images to PC available only for smartphones with SD card?
I dont have SD card, storage settings section contains only “Free storage limit” .
I cannot find photos anywhere. Folder android/data/com.mapillary.app/files is empty.

Hi everyone,

Thanks for your all valuable feedback on bringing back SD card support in the Mapillary Android app. Mapillary Android app 5.1.0 supports saving images on SD card and transferring Mapillary captured images to the PC. Please let us know if you have further feedback on using SD card for your captures.

Happy Mapping :slight_smile:

@asturksever @Anders
Please include in the future Mapillary Android app update a function to copy/move photos from internal memory data cache to SD card using Android functions. This would allow to use the app as the user wants: internal memory only, internal memory and SD card copy as manual backup, SD card memory only. On non rooted devices file managers (even with elevated Read all files permission rights in Android 11) cannot view Mapillary cached photo files, as was the case earlier. The pictures in internal memory are only delete/uploadable and cannot be transferred to PC for further editions. Copy/move function inside the app would help to adjust the app to the workflow the users want. Looking forward to this update.

1 Like