Cannot access Mapillary photo storage on Android device via USB

It’s laughable that Facebook, famous (or rather, infamous) for tracking and logging users’ activities online (even when not using their app or service), is suddenly so concerned about privacy!!

5 Likes

I think we are reading this the wrong way around. I think it is to protect Mapillary/Facebooks privacy. Maybe they are storing lots of extra information while we are taking photos, and they don’t want us to find out about it.

Because, as everyone agrees, this can’t have anything to do with our own privacy, or that of the people in our photographs. If it was, the various privacy groups would not allow us access to our own photos in other apps either.

3 Likes

I have the same problem too. Where i am now i cannot upload photos via Wi-Fi and i have the Android smarphone almost full of Mapillary pictures (50 GB).
It’s a mess

It was very useful when i copied the folders on my laptop and I emptied my smartphone in order to be ready for new mapping activities. It seems not possible anymore.

3 Likes

Same here on LAOS 11 Sony phone with 3.174. Come on, I can’t upload and I cant move the photos to my PC for manual upload???

How can I continue to contribute?

1 Like
3 Likes

Any APK for non Google Android users?

Does this mean it’s also possible to access the pictures themselves on the phone? If so, where can we find them, where are they stored (also in case the phone only has internal memory)? I tried to find them, but couldn’t in a first attempt.

@Loek Currently, this version only supports accessing images within SD card. We’re exploring to add this feature but it is not possible at the moment.

Thanks, I’m looking forward to also have that option.

1 Like

Hi!

The same question from me: where can I find the photos on the phone? I’ve installed app version 5.1.0 on my phone, but can’t find the photos or any settings about that. Can you help me, please.

Alternative: Can you (or anyone else) point me to another app to record photos in the same way? I’ve tried “Open Camera” which offers some features but not all (no stop when standing still,…).

gzin from Austria.

Finally! Now that I can access the recordings myself, I will start contributing to Mapillary again.

1 Like

How does it work? Where can I find something in the gui?

I’d like to take pictures with another app and upload with the desktop uploader. Upload works but I’m still searching for a good photo app. Any suggestions?

Mapillary App 5.3.7.2; Android 10; Galaxy S9

I cannot get Mapillary to store images on the microSD.
I cannot see any (recent) Mapillary images on the phone from the file explorer on the phone nor from Windows (when connected by USB cable)
I also have experienced twice that an entire sequence became un-uploadable (the App says "The sequence has been converted for processing … " but the upload does not work)

What’s going on?

@voschix Thanks for reporting this issue.

Mapillary App 5.3.7.2 supports storing images into SD card. I’ll check this out with our Android Developer. Do you see any prompt message when you try to save your images to SD card? If you can share screen-recording to the support, it might be helpful to debug this issue.

Mapillary App does not support accessing imagery when the phone is connected via USB. You can only access images by inserting your SD card into your PC.

I’d recommend you to log out from your account and login again before re-uploading them, this should help.

@asturksever
An update:
I managed to access Mapillary data (as in the old days) on the microSD of my Galaxy s9 from my Windows 10 computer.
I can do so via USB cable connection without moving the microSD to the computer.
BUT it works only on a virgin microSD card. It does not work with my older microSD card that also had some older-version Mapillary data on it. In actual fact I could not set the image storage to the card in the that case.
I only now realize that the switch to enable SD card recording was shown not to work (attached screenshot 1), but on the fresh card it shows the successful switch (screenshot 2)

Would be a good idea to document that behaviour on the Mapillary web presence.

1 Like

Note that the UI is quite broken here. On my phone, that toggle also is gray. However, I don’t know if that means it’s disabled, because I can still toggle it off, and it stays gray! I can then toggle the gray button on again, with the app asking me for confirmation if I want to save to the SD card. I haven’t confirmed there to check what happens, out of fear it may delete existing images on the SD card. (The app is so unpredictable in places, that I wouldn’t be surprised if it did that.)

My interpretation: the toggle switch works, but if the SDcard is not available or accessible for whatever reason it defaults to the phone memory. I guess that there is a problem with the files Mapillary leaves behind on the memory card, even when you have downloaded the images.

Is there any other way to obtain images obtained via Android without USB? For example, can you download it after uploading?