Upload is stuck on Android app

App version: 5.0.2 on Android

Haha, can’t even upload screenshots to the forum: “access denied”.
Is there one thing working at Mapillary?? Maybe it is time to find normal developers.

I try to upload. It says: “2577 images in 9 sequences…” I press upload and then it turns into “Upload in progress” but doesn’t actually do anything. I left the phone uploading for several nights. Uploads are stuck from June 19th. The new app simply doesn’t upload and locks the sequences so you cannot do anything with them. Please return the old app. It worked somehow.


Same for me. Sequences got locked after loosing connection during upload. 1536 pictures in 10 locked sequences.

One way would be to root the smartphone to get access to hidden folders and use another method (computer desktop) to upload pictures.
Another method would be to uninstall the app so one can at least remove sequences from the internal memory of the phone… and loose pictures.

Yeah I guess it’s time to finally leave Mapillary as it’s no more any interest in forming a community. I also pinged them on twitter, but no reaction https://twitter.com/OSMMV/status/1433117516998512648
Seems that it’s only interested in Technology and it’s integration to facebooks tech labs…

I will do some tests with kartaview/openstreetcam and see to create a personal photo repo to do SFM on my local host

@Ser9ei999 @8of9 @Eric_S Apologising for our response! Recently, we released Mapillary Android 5.0.8 with upload improvements. We’re also working on bringing back SD card support and I hope you’ll not experience similar issues. Thanks for your understanding and patience.

Wow, what a progress! The uploader stopped crashing and I’ve been able to upload all the stuck sequences but the very first one. It just says “upload in progress” and not showing any progress. Tried to restart it three times. Left the uploader in this state for the night. Nope. Still no progress.

But still it’s a huge relief after getting rid of 20gb of dead load on my phone. At least I can use the app again.

1 Like

And ofc there are hundreds of pictures in the sequence and not only one as the uploader says.

Same for me. Last version (5.0.8) didn’t succeeded in uploading my locked sequences.

@Eric_S Can you get debugging log files for this time? If yes, can you share them with us on your support ticket.

Thanks for letting us know that you managed to upload most of your sequences. Please, can you send us your debug logs? Thanks

Log file is still empty, even with the new 5.0.8 version. Same as as mentioned in the support ticket, on Sep 29.

1 Like

So where is a APK for a phones without the Google Playstore? Please link / host it again so FLOSS powered smartphones can be used again

Sent the logs to the logs email.