Mapillary App Fails to Upload - iOS

Hi,

I’ve been using the app to take pictures but after I u
pload it says something like 0/5 sequences uploaded and the five sequences are still there in the app. I’ve tried multiple times but same thing always happens. It’s quite a lot of images so I’d like to try and upload one of the sequences first but every time I retry I’m forced to upload all of them again as I can no longer click into one sequence. When I click on one sequence it says the sequence is locked. Can someone help?

Here’s the error message: 897-E829-E-4-CE0-4683-9-C53-5947-E1841-E96 — ImgBB

Thanks

When they have been converted to the internal format, the sequences are no longer viewable, sorry. We want to bring back this functionality to view and upload single sequences, but I can’t give an ETA. I do want to fix the upload problem instead though, I’m looking into that now.

1 Like

Thanks @Anders, please let me know if you’re able to find a fix. I tried taking another sequence and uploading it separately but same thing happened, so now have 6 that I’m unable to upload.

I built an old version of the app, captured a few sequences, updated to the latest app in the App Store, upload went fine, so I can’t reproduce your problems.

Reading your last comment, you did a new capture and that didn’t upload either. I wonder if the upload server is blocked for you for some reason. Do y0u use VPN? Do you know if Facebook is blocked ny the ISP? If you upload via cellular, does the upload start then? I don’t expect you to upload everything using cellular, I just want to know if it starts or not.

Another thing, would it be possible for you to share some of the files with me on Google Drive or Dropbox or something similar? You can send me a link privately. I can then put them on my phone and try to upload and see if it works for me.

Thanks, no I don’t use a VPN and Facebook works fine. I’d try cellular if I could without going over my monthly limit, buts that’s not an option at the moment.

It appears to upload everything, 3-4 GB, and then I get the message saying 0/6 sequences were uploaded.

Happy to share some of the files, but if I can’t access them how can I export them?

Oh so it starts uploading? Hmm, interesting. In that case the servers are not blocked. Do the uploaded sequences show up on your profile, either in the app or on the web?

You can download the sequences to your computer by connecting your phone. Are you on Mac or PC?

I have 5 in both the app and on the web that say ‘processing’, the oldest from 12th August. I’m not sure if these are from the app though as I also use a dashcam and upload the photos from that with my computer and Mapillary tools. I’m quite sure a few sequences I took with my phone aren’t yet on the map though.

The order of the list on my profile has been quite strange for a few months now, as just under the processing sequences it jumps back to four sequences from Feb 2020 and then my most recent successful uploads. Looks the same as the problem others have been having: The order of the photos of “My coverage Mapillary” on the “Upload” tab - Web and notifications - Mapillary Community Forum

I’m using a PC and an iPhone. If I could see the photos I could check if they are on the map yet and if not try uploading another way (assuming the issue will soon be fixed for new sequences).

Thanks again!

Ok, well don’t delete the sequences from your app until you know they are uploaded and processed. Regarding the feed problems, I think a fix was submitted today. Not sure when the update gets through the system though.

For PC, you will need to install iTunes. Here are instructions: Transfer files between iPhone and your computer - Apple Support

Thanks, when I copy to my PC I get a few files, I assume the images are in the vrs files but how do I upload these? Can I do this with Mapillary tools? Any preprocessing required?

Unfortunately neither mapillary_tools or the DU support pre-created VRS files. I have filed a feature request for that now though.

Can you upload the files to some sharing service, like Google Drive, Dropbox etc? Just zip the whole mapillary folder so I get all the files. Then I can load them inte the app and hopefully see why they won’t upload and make a fix. You can send me the link in a PM.

2 Likes

Hi,
I can’t upload images to Mapillary too, and I can’t see my images anymore.
Here is a video of the problem : RPReplay_Final1643030114.MP4 - Google Drive
Regards

I think I am having the same issue for quite a few weeks now.

  • I had a few sequences which uploaded until the MB-bar was full.
  • Then I get a 0,0 kB/s status for a while.
  • Then I get an error message “Upload failed. 0 of 1 sequences are uploaded. You can few the status of your uploads in your profile” – OK

I can then not open the sequence since it is prepared for upload. So I cannot download or view it =(.
I can re-try the upload, which start at 70/70 MB and 0.0 kB/s. The same happens, if I kill and restart the app.

I tried delete + re-download of the app, which did not help either.

I tried deleting and re-capturing sessions, which did not help.
I have removed my last set of sequences and captured a new one today, which also did not help.

I am on the current iOS and current app Version.

I hoped for an update of the app, but the last update was a while back.


Hi!

Thanks for reporting. We are looking into it, but we don’t have a fix yet. If you can’t upload, it seems to sometimes work if you try a bit later, like the next day. Some users have reported that logging out and in again helps. Just don’t delete the app as that will delete your local sequences too!

1 Like

Hi,

I confirm that I managed to upload yesterday a sequence captured on last Monday (24/1) but that I couldn’t send the same day.
However, I still can’t send today captured footage.

Good luck to the developers!

Just to let you know that the issue is still there with 5.1.18. here is what I see after uploading my old sequence from the end of Jan. iCloud

The timeout is 10s so try waiting a bit longer until it shows a popup that upload failed. If that doesn’t work, can, could you try logging out and in again? Don’t delete the app as it will delete your photos!

2 Likes

I am still unable to upload sequences from my iPhone on 5.1.9.0.0

The upload stops after uploading all images from the first sequence, then stays stuck on 0.0 kb/s. I never receive a timeout message or any other error.

iPhone 12 Pro, iOS 15.4, Mapillary app 5.1.9.0.0

1 Like

Interestingly enough I was now able to upload new sequences I captured today. As soon as the upload reached the old sequences tho it again went to 0.0 kB/s with no error message at all.

Logging out and in does not help btw.

I took this video on the 17. after I saw the 10s update. Uploading my old sequence did not work. I think I waited long enough, the video is 5 Min. It will be available for ~30 days at iCloud.

Will try to re-login next but only report back should that fix it. => Re-Login did noch change anyhing.

Update: I took a new sequence which did upload. The old one is still stuck. The latest update 5.1.10 did not change anything in this regard. Will delete the old sequence now an hope at least new once get uploaded from now on…

1 Like