Uploads of locked sequnces stuck

Nobody answers in the SD card topic. So I post it here.

It seems once sequences are locked and not uploaded the first time (for example, because of the connection loss), the app won’t upload them at all. How do I force upload all the stuck and locked sequences? I have no memory left on my phone.

We are working on new uploaders for both iOS and Android that will fix hese issues. I hope to get them out this week.

I updated my app yesterday to the latest version. Nothing changed. The uploads of the locked and stuck sequences won’t resume. Just the same old upload in progress pop-up appears but does nothing.

1 Like

It’s very odd. Can you try one thing for me? Does it work if you disable wifi and upload on cellular? I don’t expect you to upload the whole thing, just to see if it starts uploading. That would help up narrow down the issue.

I don’t have a sim card in my Android phone. I use my iPhone as a hotspot for this phone. It won’t upload on both home WiFi and iPhone hotspot. Later I can insert my SIM card into the Android phone and check if it uploads. I’ll let you know.

Thanks for your quick reply! I had two theories, either that Facebook was blocked, or that the router was somehow configured oddly.

Is the iPhone using WIFI or SIM? If you have the chance to try Android + SIM, that would be great, just to see if it starts.

Another thing to try: can you upload on iPhone with the Mapillary app?

Have you been able to upload at all with the new version btw?

Can you send logs btw?

  1. Enable logs
  2. Start and let upload fail
  3. Send logs

Yes, it uploads the new sequences and then just stops still saying that uploads in progress.

I sent the logs.

Here is the link to two videos: typical upload attempts on the iOS and Android versions. Sorry for the orientation of one video, but I think it’s not that important here.

https://drive.google.com/folderview?id=1yda0HkALkBy6ZSZFpDo4_528Hgrjc44g

I used the cellular connection on both iOS and Android devices.

Android version doesn’t crash but still won’t upload the locked sequences showing the upload in progress pop-up forever.

iOS version crashes after adding EXIF and converting files for upload. I guess the files have been already converted, so it crashes almost instantly now after I tap upload.

Thanks. We think it’s a problem with the GPX file. What capture settings are you using?

Distance-based 5m on both devices. The new sequences upload fine on Android. I didn’t change any settings. I don’t think the problem is there. Only the locked and not uploaded from the first attempt sequences are stuck.

On iOS, it crashed on start-up since the move to the new servers. The start-up crash was fixed in the latest iOS version and it lets you take pictures now but crashes on upload. So still no use from the iOS version for me.

I’ve used the same settings for 2 years and everything worked somehow before the major update. Yes, with the old apps it was not smooth at all, I often had to restart the upload process several times as it could just randomly die but I always managed to upload everything at some point within a day or two. Now, I haven’t been able to upload the stuck sequences for a month already.

1 Like

Another video showing that newer sequences upload without any problem. And as soon as the uploader encounters the old locked sequence that haven’t been fully uploaded the first time it just stops.

https://drive.google.com/file/d/1rckO3441rUstsZu5e4xTt2tMLUQeZvet

1 Like

Any news on this issue. Tired of keeping the locked sequences in my phone’s memory. Especially when I cannot use the SD card.

Is anyone going to reply? I’m going on a trip in a day or so and need my phone’s memory free of old sequences, because I won’t be able to upload sequences on cellular outside the city. On one hand Mapillary says I need to take pictures in some area because they do not have coverage there, on the other hand they took the SD card away and don’t let upload the old sequences from my phone. WTF?

Hello all,

I’ve logged in this thread just to say that I’m affected by the same bug.

If one uploading session is interrupted, for whatever reason (say, unstable wi-fi connection), the photo sequence is “locked” and apparently there is no possibility to upload it. Or even view it / edit it / download it.

This is very annoying!

Combined with the facts that:

  • there is no web uploader (OS is GNU/Linux - sorry, no MacOS or Windows here!)
  • there is no apparent possibility to access phone storage for Mapillary directly, via USB cable

the application becomes unusable.

Details:

  • Mapillary Android app version 5.0.5
  • Operating system: Android 10 QPIS30.73-33-9
  • Phone model: Motorola One Fusion+ (XT2067-1)

Please let me know if there is a solution for this - otherwise I am seriously considering resetting the phone completely (losing photos), abandoning Mapillary for good and moving to alternative solutions like KartaView.

Best regards,
Răzvan