Mapillary pictures on SD-card are not accessible anymore [Solved]

All Mappillary pictures are not acessable annymore on SD card since 27 February '22.

It seems that the storage location on the SD card has changed. Uploading now takes a very long time because I cannot use the PC uploader now.

On Android? (I guess the questions should have been sorted into the appropriate Mobile apps section)

With latest version 5.2.1 in Playstore I still find the images in Android/data/{time stamped folder}

Using Solid Explorer I can open and move the files.

1 Like

I sent a message to Mapillary support about this on February 16th:

Recently (1-2 weeks?), after recording sequences with the Mapillary app under android (storage on the SD card), sequences are not visible in the Upload tab. If I extract the SD card and read it, I can find sequences inside (and upload with desktop uploader).

It only appends with one of my smartphones (J7@2016 with Android 8).

1 Like

@Eric_S Thanks for reporting this issue, we’re investigating if this is a bug. We could not reproduce this issue on our end. This might be device related bug. Is this issue happening repetitively in your case?

@asturksever Said,

It certainly seems to be device dependent.

On my Samsung S8 I find the files on the Internal storage>Android>data>>files>mapillary>CAMERA2_0

This while I have set the files to be stored on the SD card.

On my A50, the files are no longer accessible. Not on the internal storage and not on the SD card.

This is systematic on my Samsung J7@2016 (Android 8), when storing in the SD, not in the internal memory.

In opposite, it doesn’t occur on my Samsung J6@2019 (Android 10), whenever I store in the SD or in the internal memory (but I can’t use this phone for Mapillary due to other independent reasons).

The problem is gone for me today (v 5.2.34).


Still not working with v5.2.34

@Lowiekse Please can you confirm if you cannot find Mapillary directory on your SD card for your both devices (Samsung S8 and A50)?

Please, can you try to insert your SD card to your PC and check if you can Mapillary directory?

At my S8 de Mapilary directory is the SD-card accesible on both.

At my A50 only accesible via PC not on my device.

@asturksever I reinstalled the Mapillary app on the A50. Now I can access the files through a file manager for Android11.


@Lowiekse Awesome, thanks for the update!

Hello. I want to clarify the path, to be sure I understand it right. You have had the problems with accessing the files before 5.2.34 and updating to 5.2.34 changed nothing in general. But you managed to solve the issue with reinstalling the app (though the version is the same, 5.2.34), right?

Best Regards, Yaroslav

1 Like

Yes that is what I did.

1 Like