Waiting for wifi

Today, I did a small capture with an Android Phone that I don’t use very often for Mapillary acquisition. After acquisition, both at office and at home, while connected to Wifi, it is telling me that it is waiting for wifi network to upload. When I press “Import now”, button dispersers and it is back after 2 or 3 s.

Samsung J6@2019
Android 10
Mapillary 2024.05-31-6.3.22

cc: @Yaro to take a quick look

Hi @Eric_S, thank you for reporting. There are multiple reasons which can cause this misbehaviour:

  1. System doesn’t start uploading for unknow reasons.
  2. System starts uploading, but the app can’t upload data for some reasons (the app thinks that connection is not there).
  3. Images are faulty due to misbehaviour during capture. Though the app will try to upload them in 10-30 minutes if you hit the upload button at least once on them.
  4. Something totally different and trickier.

Also, I have a few questions:

  1. Were any sequences uploaded at all when you click upload button, or it’s nothing? At all, from this device and this app version.
  2. Have you tried repeating the uploading again after some time (I assume you did, just double check)?
  3. Do you see an uploading notification in the Android notifications tray on the top of the screen? It might appear or not depending on some conditions, but it’s presence will indicate the process is ok.

For what we can try to verify uploader works:

  1. Verify that device is charged like 90% or more.
  2. Connect to wifi, and disable “upload only on Wi-Fi” setting in Mapillary’s Settings. Maybe something tricks the uploader.
  3. Open one sequence (if there is only one image, don’t worry, they just have been converted to a different format for upload and thus not visible) and click upload on a sequence.
  4. Try a different sequence if step 3 fails.

cc @boris @jvujnovic

Let me know if that worked. Sorry for this misbehaviour and thank you in advance.

BR, Yaro

First screen shots:

Before asking for a new import:

Second after asking for a new import:

I tried with cell data off, with 90 % battery, disabled “Import only with wifi”.

There is only 1 sequence (67 images). Nothing was uploaded. I think this is the first time with the last app version. (previous import on April 30). Account is Cyber_E.

BTW, where are pictures supposed to be stored on the smartphone?

I can watch the sequence in Mapillary app but can’t find them on the SD card where they are supposed to be stored.

Ok, I see the point. The storage is a bit more complicated nowadays than it was before. Where and what is stored depends on your Settings. To follow-up here:

  1. Do you have “saving to SDCard” enabled?
  2. Do you have “save images to shared storage” enabled?

also, @jvujnovic you know more details here, please follow the thread when you have time.

BR, Yaro

Yes. This is my choice.

Yes. I was not aware of such an option.

Ok, now I get everything, thank you for help @Eric_S.

First of all, I assume your device is rooted as you have access to internal app files (e.g. status.json, vrs and gpx). Those files are in a different place than images itself. Images you will see in sdcard/Pictures/Mapillary (or media in plan b). And they must be on sdcard based on your settings.

Now lets slowly dive inside the uploading process. VRS file is actually the file which stores the image for uploading. If I’m not mistaken the size is 804 bytes (i.e. octets, which I see on the screenshot). This brings me to an idea that the conversion has failed, the file has to be much bigger.

So, what can we do. If you can find images on your device, then you can upload them with Desktop Uploader (copy to your pc first). Alternatively, if the images are there, you can delete VRS file and status file, and the app will start the conversion again. The second option is a bit riskier, as conversion don’t fail because of no reason, something might be wrong with, for example, images.

If images are not anywhere on SDCard (actually at least one must be, as one image we keep until we are sure the VRS is uploaded), then there are no options left than just remove the sequence, something went terribly wrong, and images were lost.

If the app doesn’t work for you with “save images to shared storage” (we haven’t seen any cases where it doesn’t work) you can disable this setting and use the app in the old way (anycase you have access to hidden files :slight_smile: ).

Let me know if you find the files and if you uploaded the images (or it failed).


BR, Yaro

No, my device is not supposed to rooted. :sweat_smile: I just activated the developer options (for moke location with RTK).

I was able to find pictures in sdcard/Pictures/Mapillary. I copied the corresponding folder on my desktop and uploaded it using desktop uploader. Overall size of 118 MB. Both internal memory and SD card have enough space to handle that. I’m able to watch all pictures inside Windows. I will see if online processing is correct.

If you have any question before I remove all of this from smartphone and computer, don’t hesitate.