No uploading from app (android6)

I have a new phone (Redmi 3S android 6.0 MIUI 7) and tried Mapillary for the first time. I have captured 2 sequences but when I try to upload it seems that nothing happens.The screens says "Upload in progress… Uploading your photos, you can continue using the app … " and 2 “buttons” saying CANCEL and HOME. Nothing seems to happen. Any idea as to what goes wrong?

Hi @peewee32! Thanks for reporting your problem - I hope we can help! Could you please go into Settings and under Developer check Save debug logs to file, then try the uploading activity again and send us the logs to Great if you remember to mention your phone and Android version there as well as you so nicely did here. =) Thanks! PS Just to confirm, is this with the latest version, 3.03?

I sent the logfile. I was using the 3.03 version of which I sent this logfile. After sending I found out that there was a new version available (4.0). I installed and tried to upload again …but… does not seem to work either. I sent that logfile as well. I hope you can work out a solution.


I got it working now. I changed the next setting on Android. Security (separate app on Redmi)> autostart> Check Mapillary. Not sure what this autostart does but it seems to do the trick.

Hi @peewee32, thanks for sending the logs! But even better that you figured out the solution yourself already. Good for others to know if anyone experiences something similar in the future.
But - app version 4.0? I don’t think we have that yet… 3.03 should be the latest.

I guess you are right about the version. I must have mixed it up with the 4 star rating on google play. :smile: anyway… I have the latest version now. I just got notified that the images are on the map. When I look at them I see that the images are flipped 90 degrees and also facing in the wrong direction (also 90 degrees) Any idea how this could have happened? Setting in the app maybe? Can this be corrected? Here are the 2 sequences.

Honest mistake in that case! I actually did that with another app not long ago. What can you do, it just stands out while for the version number I have to scroll down :smile:

These are nice long sequences! Sorry about them being rotated, this is a known problem to us that we’re hoping to find a solution for. So it’s nothing that you did wrong. I’ve noted this down and we will turn the images into the correct position for you (please give a few days).

As for the compass angle being off, this you can fix yourself by using our editor. In the web viewer, click on the three dots (…) icon at the bottom right, where you can choose to edit the current sequence. Then you can either choose to apply the same offset to all compass angles by the same value, or “normalise” the sequence which will make the CA of every photo face the next photo in the sequence (which is the norm when you move forward with the camera facing forward). The changes you submit should get approved within an hour.

I see the images are rotated now but unfortunately they do not look good.


When I download the image though it looks OK. Can you fix this on both sequences?

@peewee32 thanks for pointing this out, we think we know what the problem is and hope to fix it soon.