Mapillary website not loading

Shortly after tagging was introduced, the website stopped working for me. I can no longer view maps, images or my profile.
When i get emails like “The requested edits on your Mapillary images are approved”
and I try opening the included link (or just plain try to explore images), the website loads only as far as MapillaryLoadingStop
, which is rather unhelpful. Any ideas why? I’m using Firefox on a OpenSUSE Linux system.

I also have the same problem since 1 week on two different computers on two different networks when I use Chrome. It works on both with the MS Edge browser.

I also find the tagging validation game so strange that I think it must be wrong.

1 Like

I also had the same problem. I fixed it cleaning the browser’s cookies and cache.

I got this problem too with Firefox. Since i use Opera browser with Win 10 it works perfectly

On computer 1 clearing cookies and history in Edge did not help. But resetting in Chrome solved the Mapillary website problem.

On computer 2 resetting in Chrome makes no difference.

Now I have a correct traffic sign in the upper right corner of the validation game in Edge .

Same problem since a couple of days with Firefox (52.5.2) both under Win10 (64) and Win 7 (64). Ok with Edge on the same Win10.

I was not very clear but I have the same problem as the first commenter of the topic (i.e. blocked on loading progressbar). It doesn’t seem to be related to mapillary status. This morning, it is OK with Win7 but still blocked with Win10(64bits)/Firefox ESR (32bits). I tried deleting all cookies related to mapillary without effect.

Website again OK since yesterday with firefox under win10.