Mapillary map not loading [Solved]

I’m finding Mapillary gets about 80% of the way through the loading of the progress bar and then stops. I’ve tried several browsers and computers (all macOS) and had the same issue. Even a clean install of a browser had the same issue. Is anyone else having the issue?

I’ve following the sign in link from the home page https://www.mapillary.com

Would you perhaps make use of some java / script blocking plugin? In that case you’d like to (temporarily) trust something like fbcdn to run scripts to progress beyond 80%.
Best,

I’m not aware of any browser based blocking scripts.

I’m wondering if the new macOS system level try and make trackers not track you by bouncing those requests through other proxies, is what’s tripping things up is what’s causing the problem? I’ve not had any issues on any other site yet.

The lines below may -or not- help ,: checked whether anything is blocked in Ghostery and the EFF’s Privacy Badger plus NoScript and Cookie Quick Manager, visiting www.mapillary.com, and logged in to www,mapillary.com/app and forum.mapillary.com .

Approached the sites with both Firefox and Edge on Windows 10

https://www.mapillary.com (the page with lots of black background, largest text : “Make better maps” :

  • Ghostery shows no trackers detected ;
  • Privacy Badget shows no trackers blocked ;
  • NoSript : www.mapillary.com and www.fbcdn.net are allowed to run scripts.

‘Go to app’ opens Mapillary :

  • Ghostery shows no trackers blocked ;
  • Privacy Badger allows a.file.openstreetmap.org plus the b.file and c.file versions ;
    ‘returning control’ to Privacy Badger still allows the OSM background tiles to be rendered.
  • NoScript : in addition to the two above www.openstreetmap.org is also allowed.

Cookie Quick Manager plugin shows nine cookies, all from mapillary.com - that includes the help. and forum. subdomains.

Final thought - from a mail server , when ‘legitimate’ messages can’t be authenticated : the time-out for their reply could be set too strict. : that would be outside your control, in addition to Mapillary this could be caused by your ISP or elsewhere along the line. Posting here would be a good way to elicit other Mac-users to report similar ; if no-one does …

Hope the issue resolves,

met vriendelijke groet (Dutch for ‘with friendly greeting’,

I’m not using any extensions, I’ve reduced the various security restrictions in Firefox, and still getting the same issue where the home page https://www.mapillary.com/ works fine but the map Mapillary just gets 80% of the way through the progress bar.

I presume you’re able to access the map fine.

It’s like this in multiple browsers. It’s been like this for days. Seems like no one at Mapillary ever bothers to log into their web site. Or at least not with a modern browser.

Working fine for me, Chrome under Linux with uBlock Origin active.

1 Like

Thanks @allen for reporting this issue. Can you please confirm whether ‘Enhanced tracking protection’ is disabled?Enhanced tracking protection on Firefox causes this issue to download Mapillary web app. Please let me know if this helps.

i had the same issue, and solved it by removing “?login=true” from the url and hit enter
This has bring up the Login Window where i had to provide my Logincredentials…

This has solved it for me too, thanks. So there’s something going wrong when those parameters are provided.

Thanks for the reports and narrowing it down to the login parameter. The issue has now been fixed!
Accessing the map from any “Sign in” links will load as expected now.

4 Likes

Thanks for fixing it.