No longer working in Firefox

The web interface is no longer working in Firefox. It just shows a blank page with a progress bar:

I turned of tracking protection see if that was blocking something but that didn’t help.

As I see you have a Mac you can also use Safari or Chrome.

In addition to turning off tracking, also run in private browser. That worked for me (on linux).

But if one doesn’t want to use those browsers, and prefers FF, the trick that solved the problem was starting up in a privante window. (FF on MacOS)

I had almost this exact issue (there was a little bit more text on-screen). I resolved it by unblocking “” within NoScript. Perhaps you have a similar extension or blockage enabled?

If you use Facebook Container for Firefox, you need to allow Mapillary in that container. This is what worked for me.

1 Like

Yup, looks like Mapillary loads a bunch of stuff from Facebook now and it all gets blocked unless you allow in the Facebook container. Frustrating but at least there’s a workaround.