Do you have problems with the new viewer?

The new viewer is awesome and a great thing for Mapillary - no doubt about that. Unfortunately it does not work on 2 of the 3 computers I have access to. I have filed bugs on the issues, but would like to hear if others see something similar. That could help the staff prioritize the bugs better.

Issue 1230
When I enter the viewer from the front page of Mapillary I see nothing. When I go to a sequence from my profile, the viewer itself works fine. There are no WebGL effects, but WebGL does not work in that browser. But there is no map, which may be the issue in the first place. See the issue for stack traces.
I use the newest Chrome on Linux Mint Debian Edition.

Issue 1282
When I see the map, only some names and part of the sequences are drawn. Most often in the left part and routes mostly in the upper left corner. See the screenshot on the issue. If I move the map, some of it may be partially drawn for a short moment.
This is on Windows 7 using the newest Chrome. It is at work, and they does some SSL man in the middle stuff. I don’t know if that is the reason and Google Maps and OSM works fine.

so what is the planned/existing solution when a browser or a PC does not have WebGL supported?

Because on work I have an older Firefox where I also get only a grey area instead a map …

is it possible to add an alternative hint for older browsers?

1 Like

There is a fallback when there is no WebGL. It works fine for me.
I also have problems with the map and have filed bugs mentioned above. If you think they looks like your problem too, I would be glad if you will write it on the bugs, so the team can prioritize the bug.
If you think it is a different issue, I suggest you file a bug on .

Before loading the map, press F12 in Firefox. Then load the map. In the box below, select the tab called Console (if not selected). Mapillary can really use the lines with an triangle and an exclamation mark on the left. If you don’t want to use GitHub, just paste it here and I’ll bring it on.

1 Like

The picture viewer (e.g. works fine for me. The map (e.g. , on the other hand, is blank.

@RussNelson, @tryl, @xerst I’m going to give the viewer WebGL detection a proper look beginning of the next week, so we can iron out the situations where it’s partially supported. I’ve got VMs in place to test out @tryl’s config.

Would be great to know what browse and system you’re using @RussNelson and @xerst. Thanks for the feedback!

1 Like

Great, @knikel ! Let me know if you have something in beta I can try out. I can try the windows system at work and the Linux system at home.

Hello @knikel,

at work I have a Windows7 PC with an ancient Firefox 24 …
I hope that one is not to old in general for the recent map display of Mapillary.

And Thanks for your effort!!

@tryl, @xerst, @RussNelson: We’ve deployed sticter WebGL checks, it should behave a bit better now. Let me know how it behaves on your machines? I’ve managed to test a lot of cases, but I cannot emulate partial support (e.g. WebGL present, but lack of hardware acceleration). It would help me a lot if you could run mapboxgl.supported() command in the console while you’re on I’d love to know, if it still fails for you now. Thanks a lot for your time guys!

1 Like

Chrome on Ubuntu 14.04. Works fine with Firefox.

mapboxgl.supported() returns false and I get the old map with blue sequences.

In general it works, and the paths loads much faster than they used to. But when it renders the map or loads paths, it some times zooms out. I have tried to reload the page to clear all events, but when I press the + icon and waits for 1-2 seconds, it often zooms out 1-3 times. When it has stopped, I have also triggered it by moving the map, so new parts are rendered.

Is it trying to adapt, so all of the sequences that are loaded can fit inside the map?

@tryl great! So now we can guard against partial WebGL support correctly. That is correct behavior in that case. The annoying zoom out is also fixed. We were relying to use the bounding box as a source of truth for map view (which makes a lot of sense for the WebGL viewer where the zoom levels can be any Float value), but that of course resulted in the weird behavior on a fallback map where zoom levels can only be natural numbers and the map tried to fit the bounding box which resulted in zoom jumps. This is fixed now as well! Thanks again for helping out guys!

1 Like