Mapillary Uploader - Unable to Sign In [Solved]

I can not sign in a win 10 laptop.
When sign In with my password. I receive following message:
Error: spawn UNKNOWN

Any clues ?


@filohipo we may have this fixed now.

  1. Can you attempt again?
  2. did you change your password since June 10? Or did you sign up for this account since that data?
  3. Can you make sure to try multiple browsers?
  4. Any success on mobile for sign in with browser, or with mobile Mapillary app?

I can not sign in with Mapillary Desktop Uploader in a
old laptop with W10 installed. No problem sign in with web browsers

I ve had this same problem months ago in a desktop with W8.1 instaled, but somehow it was solved after trying a lot.

Now Mapillary Desktop Uploader is working in desktop but sign in on laptop is still not working

No changes of password were made

No problems with Android app or with any browser.

PS: I did not sign out from desktop, even when this desktop is shut down


From bad to worst
I can not sign in Mapillary Desktop Uploader neither in a Win10 laptop neither in a Win8.1 desktop

After a 48 hours of “Error uploading” in the desktop PC I re-installed Mapillary Desktop Uploader in both machines, even changed passwords.
Now I m stucked, I can not upload 20Gb photos from the GoPro camera anymore…

1 Like

Wow, missed this post. Made a very similar one just now. I guess I can delete it. I am having the exact issue (after getting upload errors, I am now unable to sign in at all).

Any update on this? I’m in the exact same boat. I had our IT add an exception for the uploader software because I think it was getting blocked, but I am STILL can’t sign in.

1 Like

have you followed this?

1 Like

Yes, and may I say it now ? Unfortunetely !!
At present I have only acess to mapillary web page with the new password.

What is strange, is that Mapillary Desktop Uploader recognizes wrong e-mail ID and wrong passwords.
With correct password I receive a error message in a rose/red rectangle : Error: spawn UNKNOWN (laptop with Win10)
and a blank rose/red rectangle with nothing written (Desktop Win8.1)

PS: I ve uploaded a 1.3 million photos so far either using Android app (2 Android phones), Web uploader and Mapillary Desktop Uploader

I think the desktop uploader is not playing well with my office’s security software. That is my guess. I was able to dump about 2,000 images on my google drive and upload them on my home computer last night. Not perfect, but I’ll take it.

I had a similar problem, but after installing Python 3.6, I was able to login straight away.


Can you explain step by step what you have done ?

Please comment here to me if you are still unable to log in. If you could not, but it changed, please let me know what changed (like installing a newer version of Python).

We have a next update coming any day now as well to fix a few bugs.

I can not sign in for Mapillary Desktop Uploader, installed both in laptop (Win10) and a desktop (Win 8.1).
I have installed, re-installed , changed passwords, and received always the error message “Error: spawn UNKNOWN”
If I try to sign in with a wrong password, I receive the correct message of wrong password, try again…

The old version of Mapillary Desktop Uploader was working in the desktop. Never managed to work in laptop.

Have not tried to install Python yet, due to a lack of step by step instructions and short in time to try it.

Hey filohipo, could you share your processor and system type (you can find it in settings → system → about) here, or send to

Intel Core i7 CPU 860 @ 2.80 4 gb ram SO Win 8,1 pro 32bits

Intel Core2 Duo CPU 2,53Ghz 3 gb ram T9400 Win 10 Pro 32 bits

Thanks filohipo, Desktop Uploader only supports 64bit at the moment. I will ping here when 32bit support is released.

Why btw, my systems do not warn me? Why it seems that I have Mapillary Desktop Uploader instaled in both machines ? Why you do not inform people ?
Quite strange indeed

Idem for me today. I have an ‘error’ message with thé Windows uploader when login.

Same here. Just confirmed my account today (password reset). Uploader 2.0.0 displays Error message only. W10 19043.1081. No problems to sign into the web app.

Surely your windows SO is a 32 bits :frowning: (as mine is )