Mapillary (Android) 5.12 is out

@Ser9ei999 and @Lowiekse please be informed that I’ve been able to find the issue concerning empty folders. The fix is ready, but I will need to test the build for at least a few days, to be sure there are no side effects.

Also, during my tests I didn’t have any gaps in my captures, which means that empty directories are created additionally to a normal one, and do not influence the capture process (I mean you have more folders, but at least no missing and not captured places). Please confirm that you have no gaps in your capture path.

The fix will eliminate creation of the new folders and remove all the old empty folders if you have those in your sequences directory.

BR, Yaro

PS During my debug sessions I found and fixed an old issue of Android uploader (if you upload from the device), which fixes the case when only one image is uploaded instead of the whole sequence.

1 Like

Hi Yaro,

Top that the problem of empty folders was found and solved.

Please confirm that you have no gaps in your capture path.

If you look here, you can see that there are a lot of hiccups in the sequences.

1 Like

Thanks for the answer @Lowiekse. I see that two of your sequences have only 1 image. Also, the upload date is Apr 29. That’s probably the version which had problems with the camera freeze, which caused this small sequences. This issue is fixed in version 5.12.99 (Which is live since May 12)

Also, do you Desktop uploader, or do you upload from the mobile app?

Asking as a mobile app had one uploading issue which causes a problem of only 1 image being uploaded - will be fixed with 5.12.103 (and higher) which will be live in a few days (testing is in progress).

Just in case details of this uploader issue: if the user refreshed the sequences list while the uploading process initializes itself (i.e. after clicking upload) it might kill an init process which will restart with losing already converted files.

BR, Yaro

Mobile app, because I cannot transfer the files to my PC due to Android’s security.

This problem is new?

@Lowiekse no, this actually an old (like 5-6 months I guess), but pretty rare issue. We didn’t know how to reproduce for a long while, just noticed that it happens from time to time. Finally found the cause and fixed. Decided to mention here just in case.

I was capturing during the last weekend, reproduced the error (lost two sequences) but understood the reason.

BR, Yaro

Thank you for the info. I guess a few sequences were lost that way then. Sometimes the app seems to get stuck. Then I try to refresh it by pressing the upload button again.

BR Louis

1 Like

@Lowiekse and @Ser9ei999 I have sent to open testing an updated version (2023.05.15-5.12.105) which doesn’t produce empty sequences/folders.

Please let me know if you have any problems with the build. I expect this build to fix the rest of the problems that have been reported in version 5.12.

Best Regards, Yaro

PS The code also includes cleaning the old sequences, which are broken (i.e. empty). As the change has deletion operation, I took a bit more time for testing. So far, I didn’t reproduce the issue and didn’t have any case of miss-deleted sequences. Hope you will have the same results :slight_smile:

1 Like

How come the app uses 1.73 GB of data storage on my mobile?

How to use low resolution images on this new version
Whatever i do, they are big ones, like half hours drive, at least 2-3gb in storage
Mobile is samsung s7
Best regards

Hi, Yaro. I tried to shoot with the app today. And it works much better.
few large gaps in a 20km drive

but still quite a number of smaller gaps

Also, the compass is not working for me any more. Orientation of photos is always off.

Hi @Lowiekse, I have to guess here a bit, but do you use SDCards? If yes, please try to enable disable “save to SDCard” flag. Maybe some sequences saved to different folders.

If no - I need a bit more details about your setup.

We might avoid searching for the reason, as I’m quite sure that’s some very corner case. You can just clean Mapillary’s data in the phone’s settings (please double check you’ve uploaded everything from your sequences list) and restart the app. The app will not even ask you to login again.

BR, Yaro

Hi @vancasmik thank you for the question. So, low resolution images are low only on some device. We have the minimum resolution the platform requires. Thus, even with the flag enabled images will be taken with the lowest resolution which we still consider acceptable.

Even though we can go deeper into details, there might be no need as from the next version (5.13) this flag will be removed from the settings. The idea is that less images with better quality is preferred to higher number of less quality images.

BR, Yaro

Hi @Ser9ei999, thank you for checking. One question, are you using 5.12.105? If yes, do you still have this empty folder issue?

Gaps: each image request is based in most of cases on the GPS and distance from the previous image. Usually, the gaps appear when GPS is not so strong for a moment. GPS issues can be caused by many reasons. Thanks for the report, I will look for other possible reasons or mistakes.

Compass: already working on it. The solution might be not so straight forward, as compass sometimes just unreliable in a metal cage (or a car, for example :sweat_smile:). Also, just FYI, Mapillary aligns images to the correct (mostly) angle later during the processing, there’re ways to do that.

BR, Yaro

Hi Yaro

I don’t use SDCards.

I have since cleaned up Mapillary’s data in the phone’s settings.

That’s probably the simplest solution for now.

It could have been a known issue.

BR, Louis

1 Like

I had two rides of 1:20h each last Sunday, with 5.12.105, and all problems were gone. No gaps, no empty folders. Worth mentioning I use internal memory only, on Galaxy S10.

1 Like

Did anyone experience a serious heating issue while capturing? Or maybe someone found the root cause of that?

I’ve seen mentions about crashes caused by overheating while capturing. That might be because of the app of course, but I would guess the main reason is something like direct sunlight.

BR, Yaro

This would merit a new thread.
I can only take pictures in time lapse, not anymore picture by picture.
After a few pictures the screen turns black and I have to struggle to stop the sequence.
But the problem is that I cannot take the pictures I want and that it becomes fuzzy.

The user manual is unchanged.
I hope I am missing something.
The result is this =

Unimportant detail, but to attract clicks =
this picture is taken in a brewery.

Hi @Yaro
not sure if this is the best option
i always use mobile phone when i driving… i have dedicated like 10GB for Mapillary, but now this means only like 1,5h tops
so Im not sure if I will be motivated anymore more, because in hotels, sometimes takes for ages to upload 10 GB
another thing what is not good in app is storage limit. Everytime I put to 0%, and it return to 10%, so last 3GB cannot use… so 1,5h becoming 1h of collecting and this is really annoying, so i can always collect only near area around the house and everything else I cannot collect, so i dont see any point to use Mapillary anymore :slight_smile:

I am experiencing the same problem. Sometimes the app has to be restarted several times before the camera works. I have this problem in Android v5.12.105

The problem already existed and is not specific to this app version.