Change picture to upload twice?


as my pictures sitting 4 month in queue without being processed or appearing in “Upload” section of my profile, I tried to uplaod them again. No luck, with every picture “already uploaded”.
I tried changinging resolution, file date and exif date. No luck.
Any idea how I have to change my pictures to re-upload them?

(e.g. wekeknd trip, roughly 6k pictures, and roughly 1k not processed, others are online and on map).


just go through other topics concerning this problem:

Check if your pictures are visible through ID editor.

I was able to reload a printscreen of the picture.

Thx, but I do not see pictures in ID neither JOSM.
Also I do not watn to screenshot all of the pictures.
A little script-fu oneline would be nice with imagemagick, but what to change…


What’s your username? I can look into this one for you.


username: aceini.

Uploaded end of nov 2020 - Mapillary - Street-level imagery, powered by collaboration and computer vision
I can view the pictures if I follow the arrows in the screen, but no sign of track in upload view of my profile or in map view.

And uploaded end of nov 2020, to:

And uploaded sun, 27th march, after this picture:

And the pictures uploaded after this one: Mapillary - Street-level imagery, powered by collaboration and computer vision

(but both last could be still processing, as one missing off that day appeared today).


Hi, I’ve also had this issues on user iomham. We did a project to map our urban areas, but probably 20-30% of sequences never showed up the map (they show on the ID editor)

Just reviewing yours now. The majority of images being flagged look to be when your holding the camera before or after capture.

Best to delete these before upload if possible until we have a better review system.


Thanks! All of yours should be reviewed now as well.

Hi Eneerhut. Thanks for this, that’s very helpful.

Will these captures end up on there eventually? We will try and cut out the first few frames in the interim to solve this one.

In this case, I approved the flag of the images. In other words, I told the bot it was correct in holding aside X number of images in this sequence. So a few of these images will be deleted, but the rest of the sequence which is normal images will flow through to Mapillary in coming days.


I’m facing the same problem.
The image I uploaded in November still does not show up on the map.
I have already emailed to about the situation on March, but have not received a response.

Is “” working?
Can you please check the status of the image processing? My account name is “tankaru”.


2 weeks later and no pictures of the problem tracks are yet shown as “green dots” on the map.

The only images pending were from last week and I have just pushed those through. Could this be a vector tile delay @tao?

Sorry for the delay. Support is a bit overwhelmed at the moment and we have limited capacity to answer all the queries.

You have no pending images now. Do all the images you expect show up now?


Here you see two days with missing pictures.
Both days should be a roundtrip.
But this track is on my upload tab, but not in map as seen above: Mapillary - Street-level imagery, powered by collaboration and computer vision

Here we got the pictures not seen on map Mapillary - Street-level imagery, powered by collaboration and computer vision

but with the little arrows I can navigate through them.
Same as here, still not on map
(November 2020, several month ago, and noted above)


For example, this photo is not shown on map.


Great, today I see all my missed tracks online on the map ._)