Build 344 broke the focus and other issues

Build 344 broke the focus on my S5 on android again. Had it on continuous focus for the longest time and then this build I’m again getting 1/3 of the images blurry. I tried setting it to the infinity mode and same issue. I tried it with the auto focus with every shot which at least won’t take blurry images but I do get two errors instead, one that breaks the sequence. First being “can’t focus” and the other being that it can’t find the location at this time and then resets the sequence even when the GPS has been on the whole time. Not sure what that is about.

Additionally been having uploading issues. The new processing timing through me off the first time thinking it was uploading it as it counted the numbers down, just like it had with uploading it. It even says uploading at the top of the dialog box. If I go away from the app and look at the notification bar it shows me an accurate number of when my upload is done and gives me the proper “I’m done” text but when I open the app the dialog still says I’m uploading and wants to resume the upload. If I click resume the app often crashes.

One more this has happened twice now in the last three builds.Trying to replicate is frustrating. but when I go into menu with the app pointed down or switching between manual and automatic the image comes up upside down. Not sure what is going on here. turning the app off and on fixes it though.

Thanks for the hard work, let me know if there is anything I can provided to make it easier to figure out what the problem is.

@natfoot thanks for the feedback! Passing it on to development. What would help us even further are logs, if you could please turn them on in Settings > Developer and send us via the left-hand menu when you’ve recreated the problematic behaviour. Much appreciated!

Hi there,
getting over the logs for this would be awesome. It seems Samsung phones are notorious for not implementing their reported support of the Camera2 API. However, have you tried forcing legacy camera support in the Settings->Developer and see if that helps?


1 Like

I sent the logs in, hope it helps.

1 Like

I sent in logs too before uninstalling Mapillary. I was having lots of problems on my Galaxy S5 as each update was released.

The Camera was almost constantly focusing, never had an issue before. Any camera setting was ignored.
It would randomly stop taking images so I was missing large areas without knowing.
The uploader is a lot worse now, all this processing first without uploading. If the screen turns off I think it stops processing… I’m not sure though (confirmed by @adam).
Images are being taken at 5312 x 2988 regardless of settings meaning I’m creating more content than I can upload.

Combine that with upload problems and 1/3 blurry images I tried looking for older versions to try.
In the process I managed to delete over 20GB of images waiting to upload when I uninstalled Mapillary trying to figure out what all my problems were.

After that I completely gave up until now when I found so I have installed 3.27 which was the last stable version I remember using that gave me no problems and and before all the changes to the camera focus, uploader and capture interface.

Next time I am out i’ll see how it goes.

1 Like

3.27 = so much better.

Just went on a holiday and took 16,000 images with not one problem. Uploading them now and they are going steady, 4970 images to go after only 12 hours.

I tried the latest version today and found it did not help.

With legacy on or off it would still focus regardless of settings and take images without waiting for the camera to finish focusing.

I have gone back to Mapillary 3.27 again.

Galaxy S5 SM-G900I
Android 6.0.1

I have found a work around for my devices but will fully test when there is daylight here.

Version 3.108 code 408 to get fixed focus at infinity I found the following worked:
Camera2 API enabled, focus mode: Autofocus.
Camera2 API disabled, focus mode: Autofocus.

As I was using 3.27 code 327 for so long my settings were Camera2 API enabled, focus mode: Continuous but strangely I found that Camera2 API disabled, focus mode: Autofocus also worked.

All other focus modes attempted to focus.
Basically the auto focus, continuous and fixed focus settings don’t relate to what they actually do on my device.