[bugreport] latest ios app crashing [Solved]

With no proper bugtracker just throwing this out here.

After the latest app update on iOS, the app is crashing (or being closed by the iOS) very frequently. In many cases, the app works for 10-30 seconds, then crashes/gets closed. After some 5-8 times of this, the app seems to stay up more reliably. As one might expect, this is very damaging to the image collection experience.


Is this during capture? Mine seems as stable as usual (so not very, but usable).
I heard something about a new memory management technique introduced to iOS, with some apps requesting entitlements to continue using old style memory management

Yes, during capture. Upload seems to be fine, as is just sitting there in the capture mode, but not capturing. Haven’t updated the phone OS for a few months, if not more.

Actually had it close once while reviewing pictures before the upload, too. The only change I recall/noticed was the recent app update.

try the new version, supposed to be more stable

Having tried the latest version, it crashes/closes the same.
This is not related to capture or upload - even just starting the app and leaving it open will have it closing a bit later.
Especially demotivating when it closes 8 times in a row, while driving…

Has anybody from Mapillary had a chance to look into this / test it?

i’m guessing they are getting some telemetry, but it might be a rare case. What device are you using? Did you try a reinstall/a different device?

I’ve had similar on iOS - the app would crash after about 20 seconds, regardless of what I was doing with it.

For me, this started after I’d completely filled the memory on the phone with pictures; then had great difficulty even getting the app to start. (I’m now in the habit of taking a couple of dozen dummy pictures in the normal camera app, so if the phone does get filled up, I’ve got something to delete so I can make some space.)

After this, even after I’d emptied the phone out, restarted, etc etc, the app would often crash after about 20 seconds. Made uploading fun. Start app, upload 3 photos, crash, start app, upload 2 photos, crash.

Anyway, my guess is that something tries to download or update when the app starts up, because I’ve found that it doesn’t crash if wifi is off.

So for me, it doesn’t crash in the car (because there’s no wifi), and then to upload my workaround is turn wifi off, start the app, wait 30 seconds, turn wifi on, upload.

Great observation, southglos. While I have plenty of space on the phone, the problem indeed is related to the internet connectivity. If I disable it, the app does not crash (usually).

Dear Mapillary team, any ETA for a fix?

so it’s trying to download/cache something on start up. Maybe try changing the newsletter settings if it’s the front tab that has some rogue post, or maybe it’s the map in the second tab

the app got updated to 4.9.1 with an array of bug fixes, check it out

Thanks, upgraded to the latest version, and the changelog promisingly listed some 3 or more crashes being fixed.
Unfortunately, not only the old crash is still there, it either got worse, or a new crash joined in. Now the app will sometimes crash no matter whether internet is available or not. Sometimes 10+ times in a row while starting. Missed capturing several roads without any current imagery while thumping at the phone by the wheel.

ah, this isn’t good.
i feel like there was a support email somewhere, or otherwise message one of the mapillary reps on the forum. can you pull any app logs (ie can you browse the app files on your phone from a computer)?

After very frustrating 4 days with the app, there seem to be 3 crash conditions:

  • Crashes with internet connectivity available. Workaround - disable internet. Identifiable by the crash happening shortly afterwards the app is started, sometimes as late as 30 seconds after the startup.
  • Crashes upon startup, seemingly when there are more images (perhaps more than 10 000). Workaround - none. Keep on restarting the app while driving and curse at it. Identifiable by the crash happening before the app comes up properly, instead part of the app interface in portrait view is shown in landscape mode.
  • Crashes during EXIF tag adding. Seems to happen with a larger amount of images, usually spotted happening around 14th thousand image or so.

I had the same problem today with iOS app version 4.9.2 on an iPad. App crashed several times when uploading images / adding exif data. In my case there are not a lot images to upload (less than 100).

App crashes also with version 4.9.4

Yep, still crashes when network is enabled. Trying not to take too many images to avoid the other crash at the startup.

Things had become very bad, and the app was close to unusable - was unable to upload images at all.
Accidentally noticed that it actually does not crash [that much] with… power saving mode on. Hopefully this helps somebody else.

Just a guess - given that it crashes less with internet disabled and also in the power saving mode, perhaps this is related to some background data transmitting (although what that could be is completely unclear).

I still need to try these tips (network off, power saving on), but just wanted to say that the iOS application is bordeline unusable… Today, it seemed to work fine in the morning, with both photos and maps working. In the afternoon, it kept crashing after a few photos. Had to give up using it…

Is there some way I can help debugging the app?
Without the iOS app, I’ll have to stop contributing to mapillary…

It’s a bit messy, eh. Sometimes, the app crashes constantly. Sometimes, it’s somewhat stable (although the meaning of that has degraded significantly - this means it crashes < 10 times per day).

Maybe Mapillary is into a sociological experiment and tests what it takes to stop contributions? :slight_smile:

@Brenna, it’s unexpected to see the iOS app so abandoned. Is there any hope for it, or is it gone for good?