Android: Mapillary 5.3.25 is out

What’s new in 5.3.25 on PlayMarket ?

Mapillary for Android 5.3.25

New features:

  • Guest user flow.

  • 10 new languages.

  • User statistics in profile.

Improvements:

  • User data and user feed network operations.

  • Data transfer security.

  • Bottom navigation UI.

  • User survey (removed).

  • Mapillary satellite map (removed).

Addressed issues:

  • Hang on opening uploads with too many sequences.

  • Broken dim on capture.

  • Absent shutter animation on capture.

  • Wrong number of images on upload.

  • Wrong sorting in the upload feed.

Please feel free to share your feedback on this thread.

Best Regards, Yaroslav.

4 Likes

Remarkable release for Mapillary App Android! Happy to have user stats back on Android App as well. Thanks @yaroslav for detailed version release.

1 Like

Compass photos still don’t work properly.
If you turn on the compass direction, the compass initially shows the correct direction. But after you press the photo button for the first time, the compass jumps around 90 degrees and points in the wrong direction from now on.
This problem has existed for years and has never been corrected.
This makes the app unusable for me.

@yaroslav @asturksever can you check the compass problem?

Hi @ralrei, thank you for reporting. I didn’t have this problem in my list (didn’t know about), but I will add. Looks bad. Sorry for your experience :frowning_face:

I will try to address the issue within the next (or next to the next) open testing release.

@ralrei I have changed the compass to the state it works on devices I have. Do you participate in open testing? It is fixed there. But the app is in “testing”, thus if you need more stable (just in case), we plan to release next week.

Hi yaroslav,

I joined the open testing and installed the test version. The direction of the compass is now correct and no longer jumps when the button is pressed.
However, after uploading the photos with the app, I noticed the following:
On the website, the pictures on the track all point north, which is not correct.
The track can only be seen on the website, but not in the app.
My pictures all have a slight red cast, which I didn’t see on the display.

Ralf

Translated with www.DeepL.com/Translator (free version)

Thank you for the feedback.

North pointing - thank you, that’s valuable, I think I know where the issue is (just why? :frowning: ).

Could you share the sequence link, to see the “slight red cast”? I don’t think it will be connected to the app itself, but probably something on the backend side (just a guess for now).

Concerning the track visibility, I’m not sure I understand this one. Do you mean that in Profile in the app you can’t see the sequence, but at the same time you have it on the web app. Am I right with this assumption?

Thank you in advance, Yaro.

Hi yaroslav,

the sequence is: C7JHm9PnqTS8sW2dpBwoMk
I took another short sequence with 4 pictures in 4 different directions. The red cast can also be seen on the display. Maybe it is related to the camera api used or lack of auto white balance. When I take photos with Xiaomi camera app, the pictures are perfect.
I am using a Xiaomi Redmi Note 11S

In the profile of the app I can see the sequence. When I select a picture, it is displayed on the map in the right place (but with the wrong shooting direction). However, there is no line (track) on the map in the app, but the track is visible on the website.

Ralf

Translated with www.DeepL.com/Translator (free version)

Hi @ralrei, apology for the delay, as I have included a few other fixes in the build. So now there is 5.4.24 (in open testing) version which includes fixes:

  • compass directions after upload.
  • red images on Xiaomi (thanks for the hint when you mentioned that default camera works). Even though I don’t have a device (any Xiaomi) to check, I think it will work. I have changed the default our AWB from DAYLIGHT to Auto detection. DAYLIGHT is a bit redder on Mi series. Even a bit, it still enough to notice.

Thank you for testing. And sorry for the issues :frowning:

BR, Yaro.

Hi @ralrei, one of our users have problems with compass (crashing on capture). We can’t reproduce it on our side. Have you seen this behaviour (e.g. crash on capture with compass) on Open Testing build?

Thank you in advance, Yaro.

Hi yaroslav,

on the screen the colour of the photos now looks good, no red cast.
I took two short sessions today with the compass on. The first with manual mode and the second with automatic mode. No app crashes occurred. Automatic shots were also triggered when the shooting direction was changed. Good job!
The two sessions from Jul 20 (ralrei) currently have the status “ingesting”.

Ralf

1 Like

I’m pleased to hear that. Thank you for your feedback. Have a good day.

BR, Yaro.

1 Like

Hi yaroslav,

there may still be a problem with memory management or full variables.
I have recorded a longer sequence in automatic mode. After several minutes, I noticed that the screen display was increasingly jerky. The effect became so strong that the app almost froze. If you leave the camera mode, e.g. switch to the Explore tab and then back to the camera, the app runs smoothly again.
In manual mode, the effect is also present, but not as strong. But that may be because I took fewer photos.

Ralf

1 Like

Thanks @ralrei, I have it in my priority list. I will try to make it work right before the next release (mid August). Memory issues (sometimes, like this one) are hard to find :frowning:

2 Likes

@ralrei, we have checked the memory consumption and it looks like there in no increase even over the longer periods of time. But the app becomes slower and the phone a bit hotter (due to intensive CPU usage). And this is another problem, I will ask for more time on this.

Thank you for your patience.

1 Like