The app doesn't want to use SD card [Solved]

ah… that makes sense :rofl:

Anyway, anyone solved the issue how to use the app during a holiday? A simple hack is also welcome. I am leaving in a week to France. Can only store 3 hours of driving before phone is full. Last holiday I had uploaded 40 hours of driving :expressionless:

If you have the option to set the sd card (preferably the A1 standard sd cards) as internal storage (which involves formatting it). Then you will save more. But that’s not a hack.
Use, for example, the OpenCamer application, but you have to set it properly (there is no option to take photos, e.g. distance, only time interval.), By the way, we can choose the resolution, but I advise against taking 16: 9 photos because after sending they will become pseudo 360.

Dropping in on this topic because I can not upload any pic any way for weeks by now.
This is weird. Using 5.0.2, is this the new version? It stores 3.02 GB on external storage.
The app just can’t upload any of it though, it hangs forever at ‘Uploading’.

The latest for android is 5.0.4

Thanks. It seems to be a bad idea for me to upgrade as it will only add. this sd card problem.

And it’s update to 5.0.5.
I don’t see any improvement …

1 Like

Dear @Eric_S ,
Thank you, my preference would be to exclusively allocate the SD-card to Mapillary, unmount & swap out once full; thus any sex tapes or actually valuable data would reside in -what I’d hope is- protected internal storage, with any rogue app (which still needs to pass the regular Android safety checks of already installed apps) only being able to access the SD-card ; hence the worst that can happen is that it stumbles on some not yet blurred faces …

Hi, I know of a trick you can use. It’s a hassle though.

Install the opensource app Ghost Commander. You can find it in F-Droid, the opensource counterpart of googles Play Store, and (probably) also in PlayStore too.

Open the app and use SAF, Storage Access Framework. This mode allows you to access system-protected folders without having to root your phone. So you can access your SD card whether or not your phone allows it and you can access Mapillary’s storage too.
The first time you use SAF it needs you to pick the root folder to use, this can be either your internal storage or your SD card.

So, if you want to use a lot of disk space for Mapillary, you move the content of theMapillary data folder to one or more SD card(s).
At home you can reverse these actions to upload everything.
An alternative is to use the Mapillary web uploader on your computer.
So, not an easy hack but it does work.


Solved this issue, plz find my thread Uploading hangs.

I can not find a folder with Mapillary photos using Ghost Commander.
android//data/ is empty and i have at least 14 photos to upload

That is the correct directory. It can exist on both the internal and the sd cards memory.
Something else which is a problem if you connect the phone to the windows computer, is the window’s way of connecting by 'devices and printers, it will only allow you to see unprotected folders. This should not be a problem in Ghost Commanders SAF mode.

I’d also like to see SD card storage enabled. From what I understand it was supported in the past, and I find the reasoning very flimsy. Not having access to memory cards makes Mapillary much less useful for me, given that my phone has limited storage.

1 Like

Here is a cynical answer.
I just learned that Mapillary is bought by Facebook, so don’t expect the devs to give a shit about what we users need.

It is the power of money that counts. The users, you and me do not matter.

We want to access to our work. We are not workers, we are users. Try to do the same to the other apps of Facebook : Facebook, app, WhatsApp, Instagram and say to the user “You are not allowed to access to your pics”.


Who make this change never uses mapillary
Impossible to work without SD CARD

For me, this means the end of my contribution to Mapillary
300 gb to upload and everithing with problem - upload with command doesn’t enter, android without SD CARD, desktop cut the sequences and upload in the midle east (i am in brazil)
Why? “improve”


It’s been over a month and still nothing… It’s really impossible to use the app without an SD card for me, because I’m using my spare phone. But apparently the devs don’t care…

1 Like

Whyyyy i can’t add Image???

U can set ON SD car in Mapillary APK settings.

As I’m impacted by this too, I mostly use a S7 for mapillary, which has essentially become unusable for the purpose, not to mention trying the same on my current daily driver, i gave this a closer look.

The issue the gizmodo report is about app specific flaws and irrelevant for the discussion at hand, see for more information.

What is true is that up to Android 10 the app specific directories on “external” devices (which includes the internal /sdcard mount point and removable storage, Android terms confusion reigns here) were accessible by all apps that had the read external storage permission. For most people I believe this would fall under “expected behaviour” and not a flaw as such. From Android 10 onwards the app specific directories are not accessible to other apps in general.

The app specific directories have the form Android/data// relative to the mount point. The mapillary app used to store the recorded images in one of these directories, if you set the option, to the one on removable storage. This allowed users to, on the one hand, access their images before upload, and on the other hand use cheap SD card storage for those phones that supported it.

The new mapillary app stores the images in the private app storage that was never accessible to other apps and, on non-rooted phones not accessible to the user directly at all.

Now mapillary does have a tiny privacy point in that prior to Android 10 a malicious app could have accessed the stored images, but that was by design and not a flaw as such. Why they suddenly decided that they need to protect us against this is unclear, but regardless they still could provide access to the images via an in-app export function even in this most restrictive scenario if they wanted to (this would only solve one of the two issues, but at least that).

On devices running Android 10 and later, there is no reason not to revert to the old behaviour as the access to the app specific directories has been massively reduced.


  1. If there is a google problem please publish the apk directly on mapillary site with the function to use sd card enabled and unprotected as before.
  2. I have a rooted phone but I’m unable to find the saved photos. Where I should search?