My computer does not want to sleep

Windows 10.
My computer does not want to go to sleep after the set period. The monitor does go to sleep.
All settings are correct The power saving plan has been reset to default.

Could the Desktop Uploader be the culprit ?
Or could VR glasses I once installed be the reason ?

I have tried without any peripheral, even without the keyboard and mouse.

Have you checked that the current power plan has sleep allowed?
It’s under “Power options” -> “Change plan settings” -> “Change advanced power settings”

Control Panel\Hardware and Sound\Power Options

Yes, now I even had allowed hibernating.
And “Allow wake timers” also.

But it is not really called “enable”, but “sleep after”.

Now I try the multimedia settings.

There is something running that prevents the OS from thinking it is in an idle state. Many many possibilities but if it did in the past and doesn’t now, look into each new application that has been loaded since. There may also be Microsoft Update processing preventing idle. There have been updates in the past that run, fail, then revert and thus continually repeat. A look at the system log for errors is a good place to start.

I’ve never tried this, but apparently you can open a command prompt window and issue the command

powercfg -requests

Then you should get an overview of what application is keeping you computer awake.

Source: https://lifehacker.com/how-to-find-out-whats-keeping-your-computer-from-going-5924010

It has solved itself by now.
I reconnected the Samsung Odyssey+ for some days.
Maybe that solved the problem.

The Mapillary desktop uploader had nothing to do with it.