Mapillary no longer working on iphone 6 [Solved]

Appears to be running in the background but unable to bring to the foreground to use.
ios 12.5.3

On Android there is a new app Mapillary, version 1 (old app version 3.179). Check if the same on IOS.

On iOS there is only one app, which was indeed updated. I can confirm it works on iPhone SE w/ iOS 14.6, but that’s little help as iPhone 6 does not support 14.

It seems to be a problem with that specific iOS version. Another user on iPhone 5s with the same iOS version also gets crashes.

The problem is that I don’t have access to a device with 12.5.3 :frowning: I tried in the simulator with 12.4, but it didn’t crash :frowning:

The other user said that other apps recently started crashing too on 12.5.3, so not sure what the problem is with that specific version.

I just saw that iOS 12.5.4 was just released a few hours ago, can you try that?

hi Anders
just updated my iphone 6 to 12.5.4 but Mapillary app remains in the background after opening.
Unable to bring to foreground to use.

Thanks for trying that. The crashlogs I get for this bug is unfortunately look very odd and give no real clue that could be the problem. I’m trying to think of other ways to debug this.

I just noticed that KartaView behaves the same as Mapillary on my phone. I don’t recall when I was last able to use it but there was an update yesterday.
Interesting that both are similar apps and fail to open and can’t bring to the foreground to use.

It would be great if you could help test a beta version. OM your email addresses and I’ll add you to Testflight.

I have submitted a test build to Apple, once they approve it, it will available for testing via Testflight.

I am unable to install Testflight due to inability to upgrade to ios 13.0 on my iphone 6 …

“The TestFlight app must be installed on your iOS device using 13.0 or later”

Lol, what?! Epic fail :frowning:

There seems to be a catch 22 with this: Testflight requires 13.x and the crash affects users on 12.x, so I have just released 5.0.3 to the public—it’s the only way to get this out to you. it will take some time before the update is visible, but should be visible in all App Stores in an hour or so. Let me know if it works!

Still crashes :disappointed:

Uploading a new build today, fingers crossed

1 Like

The new update is out, please try it out!

Same result… but keep trying :neutral_face:

Also discussed/tested in [bugreport] iOS 5.0.0: immediate crash - #12 by Richlv :slight_smile:

5.0.5 also crashes for me.

New update coming today :slight_smile: