[bugreport] iOS 5.0.0: immediate crash [Solved]

iPhone6, iOS 12.5.3.
Mapillary was updated to 5.0.0 today. Now it crashes immediately after starting.


Emailed support and poked Mapillary on Twitter a couple of times, no response yet.

It seems to be related to 12.5.3. It seems to work fine on 12.4 and 13.x and newer. I’m trying to get my hands on a device with that OS version. Other users also reported crashes in other apps, but not sure if that’s related.

I just saw that iOS 12.5.4 was just released a few hours ago, can you try that?

Upgraded to 12.5.4, no difference.
Somewhat expected, as the previous Mapillary version worked on 12.5.3 for quite some time, and there were no issues with any of the other apps I use.

Thanks for trying that. I’m trying to get my hands on an iPhone 5s or iPhone 6 so I can see why it’s crashing. I got crash logs for 12.5.x, but they are completely empty and doesn’t look like a normal crash log at all, so something weird is up. This is my highest prio to fix.

Thank you for the reply, appreciate the help here.
If it would be of any use, I could try a debug version via Testflight.

Thanks, that would be great! I’ll let you know when I have something to test.

Heya, any luck here?
Starting a long weekend with countryside driving tomorrow, and that’s a lot of small roads 3-4 hour drive away from my usual “area” :slight_smile:

I’m thinking that the problem is with Mapbox since I had to do some manual tweaks to the Mapbox pre-compiled libraries, so that could be the problem for iPhone 5s and iPhone 6.

I have started replacing Mapbox with a different map lib, but it has proven to be more complicated than anticipated, so I’m trying a quick-fix today instead.

It will take some time to get it built and uploaded to Apple, and then they need to approve it, but after that I can send it out on Testflight.

Are you on Testflight? If not, send me a PM with your email and I’ll add you.

I have submitted a test build to Apple, once they approve it, it will available for testing via Testflight.

That’s great - I have Testflight installed, but not joined, I guess - PM sent.

Did you manage to install it? Another user was unable to install Testflight on 12.x, but if you already have it installed, perhaps you can install the beta build anyway. Fingers crossed!

There seems to be a catch 22 with this: Testflight requires 13.x and the crash affects users on 12.x, so I have just released 5.0.3 to the public—it’s the only way to get this out to you. it will take some time before the update is visible, but should be visible in all App Stores in an hour or so. Let me know if it works!

Thank you for all the help, greatly appreciated. Just updated to 5.0.3 - crashes the same way…

Thanks for testing. I’m sad to hear it didn’t help. My assumption that it was Mapbox related was wrong then and I’m not sure what to test next right now.

Any extra debug that can be added during the startup / in the crashlogs for the general version?

These older devices are becoming great Mapillary image collectors with decent image quality and plenty of storage - if the app works on them :slight_smile:

Another user sent in a crashlog and it’s doesn’t say exactly why it’s crashing, but it gave me a hint. I don’t think any logging would help in this case, it seems that the app can’t even “start”. I don’t have a solution right now, but will ask for help. I think it’s a compiler issue.

I will keep you updated.

can’t you have the old version again which worked perfectly on my Iphone6 ​​until this new firmware problem is fixed?

That’s unfortunately not possible.