iPhone SE problem


#1

Hi

New user here. Started using the iOS Mapillary app yesterday, and did my first little sequence as a trial run; all worked well. Using an iPhone SE.

Last night the app updated to 4.8.2 (238).

Did a longer sequence today, but after 10 minutes the iPhone gave a temperature warning (“iPhone needs to cool down before you can use it”) and switched off. Car was rather hot - dashboard particularly, and the phone was in full sun, so I can understand that. Ten minutes later, with a bit of air con, back to the app, which started a new sequence. All good.

However, all the photos seem to be positioned in the Atlantic, at (0,0).

If I try and edit the location of the photo in the app, it crashes. If I enter the uploads/map view, it crashes.
Uploading the sequence immediately “succeeds” (but it couldn’t have possibly uploaded the photos that quickly), the photos are deleted, and no new sequence appears on the website.

I’ve restarted the app, restarted the phone, uninstalled and reinstalled the app, and updated from iOS 10.3.2 to 10.3.3, and I still get this.

I can see the phone has a GPS location showing, and photos taken with the normal camera app get geotagged with the correct location. The app takes photos at the expected rate - if I’m moving, it’s snapping; if I stop, it stops, so it’s clearly getting GPS information, it just doesn’t seem to be storing it in the photos.

So, am I missing something obvious, have I broken things when everything stopped with the temperature alert, or did last night’s update to the app break things on the iPhone?

Cheers.


#2

Updated again to 4.8.3, and it’s working once more. Hurrah!


#3

@southglos Hi - and sorry for leaving you hanging! Great to hear that the issue got resolved with the update.
I just wanted to say for future reference that it’s best to report specific issues to support@mapillary.com which gets monitored daily. This forum is primarily for community discussions so threads might go unnoticed by our team for a while (as happened with this one). Happy mapping! =)