iOs app Gps delay


I use an Iphone 4 running Ios 7.1.2 and have experienced the following problem using the Mapillary app multiple times:

While the Gps basically works really well, and the resulting gpx tracks are very accurate, it seems like the app fails to save the correct coordinates to the pictures metadata. The embedded coordinates are behind in time.

When I start a sequence the delay is very small, but gets constantly bigger, the longer the sequence is, and the faster I move. The coordinates of the last picture of a sequence i recently took were already about 10 minutes behind. Correspondingly the gpx track also ended 10 minutes too early; the remaining coordinates weren’t recorded at all. As result the coordinates of most pictures were extremely off.

How can I avoid this? Could it be that the Iphone 4 isn’t capable of processing the data fast enough anymore and therefore lags behind? It was always set to take pictures every two seconds. However, when I used the phones built-in camera app at the same or a even faster rate, everything was fine?

Thank you!


Thanks for reporting. I did a change a while ago to maximise capture rate. It could be that I’m not giving the iPhone 4 not enough breathing room. I’ll disable this for the next version and see if it has an effect.

Planning on submitting a new build on Monday so it’ll be out on a week I believe. If you want, I can add you as a beta tester (TestFlight) and send it to you before that (still takes about a day or so for Apple to approve it). In that case I need your email, you can email me at anders @ mappy if interested.

  • Anders

Thought I’d reply here as well. The GPS lag problem should now be fixed, see here:

Latest version fixed it! I am still not sure what to do with the messed up sequences I uploaded? They obviously couldn’t be linked to others and interfere with them. Could they be of any further use or should they be hidden/deleted?

Glad to hear it’s working now!

@pau, what do you think, we should probably delete the sequences right?