Android mapillary app refuse taking pictures, bad GPS?

Since about one month I have the problem that the app refuses to take pictures and tries to wait for a better satellite fix. The device did work some version ago without trouble, and since I have this issue I noticed also there is also an option to use Google Play Services.
It does not matter if this is switiched on or off, and even worse: The position is accurate! I can verify this in other apps. It’s really annoying when i could take nice photos, but the app refuses to do so because it considers the position to not correct. So an option to turn off this behaviour would be fine.

I have the same problem with my Samsung GS5. Closing and restarting the app helps. It is not such a problem because it happens at the start of the sequence.
Of course, a less hardened person would not give mly a second chance.

I think I joined the Beta group, which is probably not true because I have no option in the settings to leave it.

I have this too. I kill the app and then it usually works right away. But really annoying.

I have created a bug:

Also Andriod issues version 169

I have noticed that accuracy info pane GPS in Mapillary (settings>Show detailed stats) is 2 times wrong when compared to GPS Status & Toolbox app stats

Mapillary GPS says for ex. 16 meter wrong accuracy but the GPS Status & Toolbox app says 8 meter accuracy.

Before Mapillary can take photos the info pane have to say 12 meter.

Best regards
Soren Johannessen

I saw online that I am a Beta tester. So I have not the right to complain.

I also tried to quit the beta program and to use stable releases instead, that didn’t fix this issue, Now I am wating to check the upcoming version 1.71 when it will be deployed from the play store, might be better then according to the discussion on GitHub.

It seems that version 1.71 works better, mayne it is just because I switched of Google Location Service. As the problem just occurred on driving longer tours I can not say for sure whether the problem is solved or not.

this might be a problem with Google Play reporting worse location than GPS only, since they also factor in WiFi etc but have less accuracy. You can see that if you enable detailed stats in the settings.


Now i can say: Problem not solved. There is a threshold of 15 meters, more than this and the app consider the position as to be inaccurate. I think that different models of phones give variant values for the Dilution of Precision, i see that i am directly in the road on Locus and there is accuracy of 22 meters given in the debug stats on the display. So I think it should be possible to adjust this value, otherwise it will always be the same as on my last trip: Half the way no picture was taken, with free view to sky and blue sky.

Hi moenk and thanks for your input!

At the moment our backend relies on accurate GPS coordinates, your suggestion of letting the user threshold the accuracy value is interesting and is something that we can discuss in the team.
Could you please open an issue in our public Github repo:
Please mark the issue with enhancement and android.

Best regards


I’m archiving this topic as we try to keep issue reporting to Github. Thanks!