403 UPLOAD Error

There is something very wrong in upload country.
Maybe the one billion error ? :slight_smile:

I have been almost continually uploading from Nov 25 to Dec 14 without any 403 errors. Using mapillary_tools (linux), not the Desktop uploader. Active 16 hours per day from about 0500z. Total approximately 1.1 million images or 1TB.

I have been using the linux_tools under Windows, btw, not the Desktop uploader …

Same here with mapillary_tools on Windows, running --interpolate_directions worked but upload returns 403 errors. Desktop uploader stuck at 0/600 images.

Same issue here, trying to upload some 350 images both with command tool (Mac OS, getting “HTTP Error 403: Forbidden” for every single file) and Mapillary Uploader (stuck on 0/350 while Uploading). Tried to delete .config/mapillary folder, re-install the app, use clear command line tools set with no luck.

Clearly, something is wrong on Mapillary side, would be great to hear something from you guys.

It’s worth noting that if the images are processed with bad auth data, the images have to be processed again, overwriting the Mapillary EXIF. Just re-authenticating (eg deleting ,config) is not sufficient. This is done with the --rerun argument, but I personally decided to also completely delete the .mapillary/logs/ subfolders in case they influenced things.

Further to my recent large upload though, (if relevant) I processed/created the EXIF/auth data 3-4 months ago and only uploaded about a month ago. (This is my workflow method)

but I personally decided to also completely delete the .mapillary/logs/ subfolders in case they influenced things.

I did just that, delete my local login/config and also deleted the .mapillary folder in my images folder. Then I ran the same 2 commands I always do (first process with interpolate, asks to login (works), then upload).
I get the same 403 error sadly.

To possibly help debug the problem I have just started a small pending upload (that I processed some months ago) and it is working fine. (no 403’s) I haven’t however kept mapillary_tools up to date (7mo old) as I have my own “higher” quality ffmpeg code in there. I also run it in a env box.

I haven’t been following the code updates either. Last commit seemed around September though https://github.com/mapillary/mapillary_tools Last change to authenticate.py was also around 7 mo ago.

Might be good to take it up with support@mapillary.com direct. I have obtained help that way in the past.

I’m running this problem too in a linux box using the last version of mapillary_tools

Tried to delete ~/.config/mapillary/config, .mapillary/* in the images folder, re-authenticate, the --rerun option… no fix.

I just send a mail to support@mapillary.com

@javiersanp Any luck so far? I’m experiencing the same problem.

No. Still can’t upload and no answer for now from support.

2 Likes

Looks like the web upload is working again (see New Desktop Uploader). However the scripts mapillary_tools are still failing (see https://github.com/mapillary/mapillary_tools/issues/358). Not sure if this is related, though.

Got hit with this, many images pending.
Emailed Mapillary support, asking to respond in this thread - otherwise it seems pretty abandoned from their side :slight_smile:

Updated mapillary_tools from 0.4.2 to 0.5.0. This version just sits there without error messages.
Running out of diskspace, will have to stop capturing images soon :confused:

I’ve created a new thread specifically for mapillary_tools: Mapillary_tools: HTTP Error 403: Forbidden

Update from my end after 3 weeks: switched from running the python script to the pre-compiled mapillary_tools.exe, re-authenticated and tried again with the untouched files straight from the SD card. A small sample of 30 files finally worked, yay. Will retry the remaining later today.

Mine is now broken. (command line uploader linux)

Deleting config and “authenticate” no joy. I note that user_permission_hash and user_signature_hash only have changed

Laterish 050 with existing images (c/- Mapillary tags) no joy. This version also seems to hang after extracting images from the mp4’s, but I haven’t run this problem down yet. (I have an altered ffmpeg command)

I have messaged support.

Hi Everyone, I apologize for the delay on this issue. We’ve released a new version Desktop Uploader v1.2.2 and tools to fix the issues we were experiencing with this.

Users having issues with the uploader will need to:

  • wait for the uploader to auto-update to v1.2.2
  • reprocess imagery by manually deleting the .mapillary folder created in the import path

Users having issues with _tools will need to:

  • get the latest tools binary (or update to the latest master)
  • mapillary_tools authenticate --advanced (reauthorize)
  • re-process imagery by manually deleting the .mapillary folder created in the import path or using --rerun

Let us know if you run into any issues with this. Thanks!

3 Likes

Nice to hear, thank you! I will check as soon as time permits.

Apart from that, can you explain why Mapillary’s communication with the community is so catastrophic? Mails to support@mapillary.com are not answered at all, there is no reaction at https://forum.mapillary.com/t/mapillary-tools-http-error-403-forbidden and there is no reaction at https://github.com/mapillary/mapillary_tools/issues/358. There are no problems reported at https://status.mapillary.com/ despite significant problems existing for over a week now.

Don’t take this personally. It is totally acceptable to wait for a fix. However giving your community, existing of volunteers, the constant feeling of being ignored is not acceptable at all.

2 Likes

@scai Thanks, let me know when you have the time to test it out.

I will actually apologize personally for this. I’m the sole person handling our entire support@mapillary.com channel, and with the holidays as well as a massive surge of emails from people and users contacting us regarding recent large-scale projects we’ve had with mapillary.com/drive, my queue has gone from a dozen or so new issues per day to several hundred. It’s been a mix of growing pains and learning experiences with how we need to restructure support as we enter 2020. Now that the holidays are over I have the chance to catch up and get back to a speedier response-time for issues like this.

I’m also completely on board with having more information added to the status.mapillary.com page - I’ve been an advocate for this and want to make it a goal to have the status page alert for user-facing issues and not just database issues. There will only be winners if we can get that running, even if it means I need to manually update known issues I see as they come in :slight_smile:

I’ll keep the forum open to monitor this better while I handle these other requests/issues, and again, I apologize that there has been a bad case of radio silence recently and will do what I can to help.

Thanks!

2 Likes