Upload fails: "403 Client Error"

Had images, attempted to upload them with some previous version of the mapillary_tools.
It failed:

requests.exceptions.HTTPError: 403 Client Error: Forbidden for url: https://a.mapillary.com/v3/me/uploads?client_id=M...

Updated mapillary_tools to 0.7.0, but the problem persists.

What’s going on, how to fix this?

should be fixed by pull request 414
https://github.com/mapillary/mapillary_tools/pull/414

you need to do a force-reinstall of the tools to get latest code.

pip install --upgrade --force-reinstall git+https://github.com/mapillary/mapillary_tools

Thank you, unfortunately still getting the same error after updating just now.

I would suggest opening an issue on github…
But error message looks strange - it’s referrring to apiv3 upload which was decomissioned…
have you tried tools re-authentication (after password reset)?
mapillary_tools authenticate --advanced

Well, duh. In my scripts, I still referenced a dedicated copy of mapillary_tools, and it was still 0.5.3…
Changing to the systemwide installation allowed upload to happen :slight_smile:

I liked the progress in number of images better, but that’s a completely different topic - thank you for your help here.

1 Like