Mapillary_tools: HTTP Error 403: Forbidden

Since about a week or more uploading with mapillary_tools results in HTTP Error 403: Forbidden (see https://github.com/mapillary/mapillary_tools/issues/358).

There has been a similar issue with Web Uploader which has been resolved. However the issue with mapillary_tools persists. This has been reported by various users.

Please check and fix your API. Various users are waiting with photos to be uploaded.

3 Likes

I was hit with this error, although it seems to have happened more recently than a week ago.
The error appeared with mapillary_tools 0.4.2. Upgrading to 0.5.0, there are no error messages printed, but nothing gets uploaded either.

Running uner Linux I also recently got hit by this (only manifested in last 2 or 3 days for me).

Upgraded to V0.5.0 and now running with --verbose I get extra info, i.e. still a 403 error but also reports “SignatureDoesNotMatchThe request signature we calculated does not match the signature you provided. Check your key and signing method.…”.

Looks like the password hashing might have changed. I can’t find where the hashed password is stored so not sure how to force it to be re-hashed.

Fixed. Removed file under ~/.config/mapillary/configs/ and re-run and they are uploading again

Thanks ralley, unfortunately removing ~/.config/mapillary/config did not help for me.
Adding --verbose with 0.5.0 shows:

AccessDeniedInvalid according to Policy: Policy expired.96E7E06226E529DC5M27HYbbyuoEQPdJFn9ISLKudSQFxwff145OcrX7njAndoZ8ISzkNTWRem4TA07hYVawlyFI2GQ=
HTTP error: HTTP Error 403: Forbidden on G0025663.JPG, will attempt upload again…

Looks like that was related to that directory being already processed. Adding --rerun got over that last one, and at least something is uploading again :slight_smile:

This “struggle to contribute” seems to be a side-effect of https://forum.mapillary.com/t/i-mapillary-closing-up .

Great to hear. However it still doesn’t work for me. Can you explain in detail how you got it working? I removed ~/.config/mapillary/config, run mapillary_tools authenticate, then mapillary_tools process --rerun [...] and finally mapillary_tools upload but HTTP Error 403: Forbidden persists. Did you use the 0.5.0 release or something else? I also tried the current master which also fails.

Removed config file, then ran mapillary_tools process_and_upload --advanced --import_path "<dir>" --user_name richlv --interpolate_directions --summarize --max_attempts 200 --verbose .

Even though username was specified, it confusingly asked for email address, and I had to specify the address that was used in the Mapillary account. Then it prompted for password, and from that moment it started working again.

This was with mapillary_tools 0.5.0.

Nope, doesn’t work for me. Still results in 403 Forbidden :frowning: Thanks anyway!

The same for me :rage:

Ah, for the directory that was touched previously, I also added --rerun - maybe that helps somebody.

I already tried to add --rerun for the process or process_and_upload action, unfortunately without luck.

Try to use Richlv solution, but still get 403: Forbidden.

Hi everyone, I’ve updated another thread about this but will do so here in case any of you aren’t following it.

Users having issues with the uploader will need to:

  • wait for the uploader to auto-update to v1.2.2
  • reprocess imagery by manually deleting the .mapillary folder created in the import path

Users having issues with _tools will need to:

  • get the latest tools binary (or update to the latest master)
  • mapillary_tools authenticate --advanced (reauthorize)
  • re-process imagery by manually deleting the .mapillary folder created in the import path or using --rerun

Please let me know if you run into any other issues and I will loop the devs in to try and get you all back up and running. Thanks!

2 Likes

Solved after a mapillary tools upgrade. I’m able to upload now.

Thank you to the developers for the fix. Only a comment. The new push is not versioned (it is using still the 0.5.0 version number).

2 Likes

Solved after a mapillary tools upgrade. Thanks!

1 Like

Thanks, I’ve let them know!

I just get the same error, so I tried to reinstall mapillary_tools by first removing it using pip and then installing it using

pip install --upgrade git+https://github.com/mapillary/mapillary_tools

The old version is still reported, though:

mapillary_tools --version
Mapillary tools version : 0.5.0

But the error message itself is more telling:

HTTP error: HTTP Error 403: Forbidden on VIRB0763.JPG, will attempt upload again for 49 more times
<?xml version="1.0" encoding="UTF-8"?>
<Error><Code>SignatureDoesNotMatch</Code><Message>The request signature we calculated does not match the signature you provided. Check your key and signing method.</Message><AWSAccessKeyId>AKIAIJJIMLWVT6GBZQIQ</AWSAccessKeyId><StringToSign>eyJjb25kaXRpb25zIjpbeyJidWNrZXQiOiJtYXBpbGxhcnkudXBsb2Fkcy5tYW51YWwuaW1hZ2VzIn0sWyJzdGFydHMtd2l0aCIsIiRrZXkiLCJ0cnlsLyJdLHsiYWNsIjoicHJpdmF0ZSJ9LFsic3RhcnRzLXdpdGgiLCIkQ29udGVudC1UeXBlIiwiIl0sWyJjb250ZW50LWxlbmd0aC1yYW5nZSIsMCw1MDAwMDAwMF1dLCJleHBpcmF0aW9uIjoiMjAyMi0wMS0wMVQwMDowMDowMFoifQ==</StringToSign><SignatureProvided>Oq3V+klfWTPjRkUs9hkbpPtIGgM=</SignatureProvided><StringToSignBytes>65 79 4a 6a 62 32 35 6b 61 58 52 70 62 32 35 7a 49 6a 70 62 65 79 4a 69 64 57 4e 72 5a 58 51 69 4f 69 4a 74 59 58 42 70 62 47 78 68 63 6e 6b 75 64 58 42 73 62 32 46 6b 63 79 35 74 59 57 35 31 59 57 77 75 61 57 31 68 5a 32 56 7a 49 6e 30 73 57 79 4a 7a 64 47 46 79 64 48 4d 74 64 32 6c 30 61 43 49 73 49 69 52 72 5a 58 6b 69 4c 43 4a 30 63 6e 6c 73 4c 79 4a 64 4c 48 73 69 59 57 4e 73 49 6a 6f 69 63 48 4a 70 64 6d 46 30 5a 53 4a 39 4c 46 73 69 63 33 52 68 63 6e 52 7a 4c 58 64 70 64 47 67 69 4c 43 49 6b 51 32 39 75 64 47 56 75 64 43 31 55 65 58 42 6c 49 69 77 69 49 6c 30 73 57 79 4a 6a 62 32 35 30 5a 57 35 30 4c 57 78 6c 62 6d 64 30 61 43 31 79 59 57 35 6e 5a 53 49 73 4d 43 77 31 4d 44 41 77 4d 44 41 77 4d 46 31 64 4c 43 4a 6c 65 48 42 70 63 6d 46 30 61 57 39 75 49 6a 6f 69 4d 6a 41 79 4d 69 30 77 4d 53 30 77 4d 56 51 77 4d 44 6f 77 4d 44 6f 77 4d 46 6f 69 66 51 3d 3d</StringToSignBytes><RequestId>C77A244D1B3A75DD</RequestId><HostId>R/ZTCd9pm2z88bWEwJKN60nuzEnKOUHMl8NIbmw9KGHdAPyGJnuIK9zypcrxj3apjpSzXC8YxhM=</HostId></Error>

Prior to running upload I have processed the images using --rerun.
Anyone who knows how to fix it?

Delete the .mapillary subfolders? Then do --rerun after redoing authenticate (see Brenna’s post above)

Yes the version number hasn’t changed

2 Likes

Thanks @bob3bob3, that did it for me.

1 Like