SOLVED:Uploading incredibly slow with mapillary_tools

Shot some pics with my action cam yesterday. Now, as always, I correlated them to a GPX file, processed, and started upload. mapillary_tools is newest version, 0.7.4. Pics were processed to be in 7 sequences.

So far, everything as expected.
Now:
ted@ted-Latitude-E5470:~$ mapillary_tools upload --import_path “Aayi/473MEDIA/”
Uploading 3177 images with valid mapillary tags (Skipping 38)
Compressing 1/7: 100%|[01:18<00:00, 6.38files/s]
Uploading 1/7: 1%
And here it’s getting annoying. Usually, for a sequence of 500 pics(2GB), it takes half an hour to upload on my connection. Yesterday, after 6 hours, it uploaded ca. 1GB, half of the first sequence, when I turned the computer off.
Today started again, and:
ted@ted-Latitude-E5470:~$ mapillary_tools upload --import_path “Aayi/473MEDIA/”
Uploading 3177 images with valid mapillary tags (Skipping 38)
Compressing 1/7: 100%
So the little progress of yesterday was lost, we’re starting the upload from zero. Speed is still veery low, and it keeps throwing lots of error messages.
ConnectionError: HTTPSConnectionPool(host=‘rupload.facebook.com’, port=443): Max retries exceeded with url: /mapillary_public_uploads/mly_tools_b0867774b4d
ae8fbfa3a7f4f0c24114e (Caused by NewConnectionError(’<urllib3.connection.VerifiedHTTPSConnection object at 0x7fcb95ed6f70>: Failed to establish a new connection: [Errno 101] N
etwork is unreachable’))
Then, it will work for some MB, and throw the error again. I think I would have to upload for 12 hours to get at least one sequence completed.

What’s wrong?? Processing and uploading with command line tools was the last thing where everything was kind of stable… well… until yesterday.
Seems like Mapillary really does not need any new pics.

1 Like

This has been going on for some days now. Last night it was getting even worse, could not complete upload of a single sequence in 10 hours. Pictures captured with smartphone and uploaded directly with the Android app are fine on the same connection. I dont know what is going on with the tools. I´m on Kubuntu 21.04, Python 3.9. The problem could also be an update on python libs, urllib or so, but Im not much into it. Mapillary upload is the only thing I´m doing with python libs involved, so I can`t test anything else. Internet connection in general is fine, down und up. Has anyone else this kind of problem?

I made a test this afternoon - there were continuous errors for a while, then about 5PM EST it cleared up and everything uploaded fairly quickly.

Thanks for the reply @MikeN
I can also confirm that it uploads at normal speed without errors now. Must have been a misconfiguration or overload on the facebook server that was going on for at least a week…

@Teddy73 : as the issue seems to have resolved itself, could you mark the subject as : 'SOLVED: Uploading incre …, ’ , please?