Error in uploading images

Hi,
When I try to upload large number of images (for example 5000) I get this error in the middle of uploading:

Uploading 4. sequence with 5 threads
Traceback (most recent call last):===========================] 100.0% … 0 images left…
File “mapillary_tools”, line 76, in
File “mapillary_tools\commands\upload.py”, line 49, in run
File “mapillary_tools\upload.py”, line 108, in upload
File “mapillary_tools\uploader.py”, line 830, in upload_file_list_manual
File “site-packages\requests\models.py”, line 940, in raise_for_status
requests.exceptions.HTTPError: 404 Client Error: Not Found for url: https://a.mapillary.com/v3/me/uploads/NgY36GfEcmYl0e8HGnW7KU/closed?client_id=MkJKbDA0bnZuZlcxeTJHTmFqN3g1dzo1YTM0NjRkM2EyZGU5MzBh
[10864] Failed to execute script mapillary_tools

I didn’t understand what is the problem and how to fix it :frowning:
Anyone can help?

Hi @bigbang001,

Recently, Mapillary has started to check duplicated files in order to prevent duplicated files. All uploading tools check duplications and uploading session fails if at least one image is a duplicate. You will be getting notification email regarding this file so you can remove these files for uploading your files without duplication. Please make sure, you do not have any duplicated files.

1 Like

Thanks but I’m sure I didn’t upload images before
when the number of images get more that 500 I get several errors:
Using upload session hc8cimuF2J6JAYAJuyX7Cu
Uploading 2. sequence with 5 threads
Traceback (most recent call last):===========================] 100.0% … 0 images left…
File “mapillary_tools”, line 76, in
File “mapillary_tools\commands\upload.py”, line 49, in run
File “mapillary_tools\upload.py”, line 108, in upload
File “mapillary_tools\uploader.py”, line 830, in upload_file_list_manual
File “site-packages\requests\models.py”, line 940, in raise_for_status
requests.exceptions.HTTPError: 404 Client Error: Not Found for url: https://a.mapillary.com/v3/me/uploads/hc8cimuF2J6JAYAJuyX7Cu/closed?client_id=MkJKbDA0bnZuZlcxeTJHTmFqN3g1dzo1YTM0NjRkM2EyZGU5MzBh
[13116] Failed to execute script mapillary_tools

I’ve been uploading this week without any issues, but as of today, I’m getting following error:

HTTP error: HTTP Error 403: Forbidden on G0011667.jpg, will attempt upload again for 49 more times

<?xml version="1.0" encoding="UTF-8"?>

<Error>
    <Code>InvalidAccessKeyId</Code>
    <Message>The AWS Access Key Id you provided does not exist in our records.</Message>
    <AWSAccessKeyId>...</AWSAccessKeyId>
    <RequestId>...</RequestId>
    <HostId>...</HostId>
</Error>

Reran mapillary_tools --advanced authenticate to no avail. Anyone else having this issue? Contacted support, will inform of their reply.

Reply from support:

There was a bug related to AWSAccessKeyId and it is fixed right now.