Uploading more than 500 photos doesn't work correctly by Mapillary Uploader (Desktop Uploader)

I’m uploading a lot of GEO tagged 360-degree photos using Mapillary Uploader (Desktop Uploader).

However, the uploader causes a malfunction before reaching 500 sheets.
https://youtu.be/-X8kGVQfrXk
If I retry it, it may be able to proceed.

However, if I get the error “Folder Already Uploaded” when I retry, I can no longer upload photos in that folder by continuing it.
In that case, I will delete all the huge logs, rename the folder and try the upload process again.

If I retry several times, I may be able to upload more than 500 sheets.
After that, it is often going well, but the operation slows down a little every 500 sheets, so I think that special processing is performed every 500 sheets in the server.
https://youtu.be/uDw1aWRGckw?t=7642
Even if the upload process finally reaches the last photo, I might still get the error “Something went wrong”.

Mapillary has a strict check for duplicate uploaded data from this spring, so I think it doesn’t matter how many times I retry it.

Also, since the same time that the check was implemented, there have been many problems such as not being able to see the uploaded photos.
https://forum.mapillary.com/t/duplicate-imports/4141/6
https://forum.mapillary.com/t/web-uploads-not-arrived-cut-at-999-images/4165/17

And when it detects duplicate photos, Mapillary will send me emails like this:
“Mapillary images or videos you tried to import failed - duplicate image file(s) detected”
But until Mapillary Uploader can handle more than 500 photos successfully, I’ll put up with these annoying emails.

In the environment I mainly use, the internet line is an optical fiber, and it can be up to 100 Mbps or more, so there is no problem with the line.

Hi, @Richlv
Is this symptom similar to yours in the article below?
https://forum.mapillary.com/t/bugreport-failed-images-always-retried/4274

I’m using the commandline mapillary_tools.
With them I sometimes see images skipped, without failures being recorded, tools hanging and other issues.
The symptoms seem different from what you are experiencing, though (and it’s a different tool as well).

1 Like

Did you download the uploader executable recently, or is it months old? I had a similar issue with 999 photos but the latest version fixed it for me. https://www.mapillary.com/desktop-uploader

1 Like

Thank you.
It was a long time ago that I did the download operation.
I will try to download it again.
By the way, do you know how to find out which version of Mapillary Uploader I am currently using?
Or do I have to judge by the date of download to know the version?