Reentry into the fortress of the Mapillary Forums

My idea was lost, but fortunately I was reminded of my idea.
I have 5 gmail emails. I tried them all to sign into the forums. 4 say they have already been used and my main email, that the bank and everyone else seems to be able to use, (I had 14 emails this morning on that email) the guards at the Mapillary Forums gate say that is not a working email.
Why does it have to be so hard to sign into the forums?
I say let people in, drop the walls, put a link right from the app,
I’m in now under the dangerous .io . I’d like to get in again under the safe .com.
I’ll have to make up yet another user name for any account I create.
This is extremely frustrating.

Why not just recover your password in one of the four accounts via the ‘forgot my password’ link?

This has been a first.
In the past I have never gotten the promised email from the "forgot my password " function.
I got one today and I’m back in under the safe .com
Thanks for promoting me to give the function another try.

1 Like

All I lost was my name and picture.

@Mmapmakerz @JBTheMilker I really don’t get what exactly your problem is.
You wrote the original post with your main account, so you are obviously able to access your account.
If you forgot your password (by the way, that is your fault, not Mapillary’s), you can use the “forgot my password”-Function (with your original username of course).
If you forgot which email-address you used for that username (that’s where the password-reset link is being sent), then you can look it up in your profile (you have to be logged in of course)

As mentioned in the original post, I entered using the unsafe .io way in.
I’m not sure what is unsafe about the .io. I’d just prefer to use the safe .com.
As for where the fault lies, I know my password. I did not forget. The same password still works in other applications. Mapillary is the one that seems not able to remember my password from one entry to the next.
I hear what you’re saying. In an ideal world what you say would be true.

It doesn’t matter if you use .io or .com. Your Account (Username and password) stays the same.
So you can go to .io (where I think you are still logged in, or you could not have written the first post), look which email address you used on that account, and then use the “forgot password” function on .com to send you the link to reset and change the password. (Don’t forget to check your spam folder)

PS: if your password does not work, then you have not used the same password. Maybe you have different passwords in the Mapillary app (or whatever you mean with “other applications”) and on the Mapillary forum (that are two different things with different accounts and possibly different passwords).

I spent some time today working on getting back in as JB the miller.
I had some small victories, but I still can’t sign in.

I guess I am signed in, just under the .io not the safe .com.
They have this pretty much bullet proof. I tried everything suggested above. I still can’t get in under .com

@JBTheMilker this does sound strange! Can you please describe what exactly happens when you try to change the .io in the URL of the page you are on into .com?

I have two saved icons on my home page. One for the .com, that is the newer one, then I have the one I first saved from an email from the “team” that takes me into the .io, side filled with perils and dangers.
I can’t, with my limited abilities, switch from one to the other.

When I enter via the ,com all safe and cozy my identity is stripped from me.

I still don’t get why you can’t just use the reset password function.
Check your emails, you should have gotten a mail from

It looks like this:

If you click on the link in the mail you can set a new password and then log in with it…

@JBTheMilker please try the password reset when you try logging in from As @B4sti4n advises, check your spam folder because the reset email might go there. Please let me know if you get the email. =)

I never get the promised email. I check the spam folder.
I went back and read the posts with suggestions about this. I get to where they say they found my account and they will send an email. I then keep an eye on my email.
The one email I did get was several days later and the link in that email had expired.
You are right when you say I should get an email.
But that email usually never comes or comes after the time limit is up.

@JBTheMilker, do you always manually enter the username and the password when you try to log in, or does your webbrowser automatically fill in one or both?

Browser auto-complete is the only reason I can think off, why you are seeing different results on and

I guess i must use the Auto complete. I dont have to enter my password every time i check the forum.