Log-in nightmare


After having some issues with the Mapillary app on one phone after completely filling the memory, I thought the simplest way to fix things might be to uninstall and reinstall the app. Nice and simple, except now I need to log back in.

My experience so far:

  • Installed the app from the App Store (says it’s version 4.9), launch it
  • Get the welcome video, press Log In, select OpenStreetMap (as I signed up via my OpenStreetMap account).
  • White screen, with Cancel in the top-right. Nothing appears, nothing happens.
  • Cancel. Try again. Same.
  • Think, perhaps I can log in via email; choose the Email option. Can’t find a combination that works, so press the ‘Forgot password?’ link. App crashes.
  • Restart it, try forgot password again, app crashes.
  • Go to PC, log out of the Mapillary website app, try the ‘forgot password’ link from that. Says it’s sent a reset link, nothing arrives.
  • Wait. Repeat. Still no reset link email, so assume I don’t have a direct login.
  • Log back in on PC, using OpenStreetMap username; that’s fine.
  • Think, perhaps if I link to my Facebook account I can sign in on the phone via that.
  • Go to my dashboard, click ‘Connect your Facebook account’.
  • Facebook login screen loads, agree to everything, says all done, goes back to dashboard page.
  • Dashboard page says not linked to Facebook account.
  • Click through to link Facebook account, again, now it just opens a new map window with ?login=true appended to the url.
  • Close, repeat, connect to Facebook link now always opens a new map window. Dashboard still says accounts not linked.
  • Restart browser, clear cache, clear all cookies, disable ad-blockers etc, try again. ‘Connect your Facebook account’ link still opens new map window.
  • Repeat all of the above PC bits using Edge instead of Firefox. Same results.
  • Go back to phone and try and log in via Facebook. Takes the login, returns to the app, says ‘Error logging in’.
  • Uninstall the app from the phone, reinstall, try everything again. Same results.
  • Email support@mapillary.com, wait three days
  • Try and link Facebook account using the settings page in the app on another phone. Get to the ‘connecting accounts’ confirmation and the app crashes.
  • Go back to the PC and try and connect to a Google account. Sign in to Google, returns to the dashboard, says ‘Connect your Google account’ still.
  • Try again, but now the ‘Connect your Google account’ link just opens a new map window, as before.
  • Try logging in on the phone via Google - get the Google login page, sign in, and get ‘Error logging in’ when it returns to the app.

This is an iPhone 6, iOS 12.2, running version 4.9 of the app.

Can anyone think of anything else I can try to get this phone logged in?



Part 2:

Tried to sign up with a new account to use temporarily.

First password rejected because it didn’t contain uppercase letters. Added an uppercase letter and it accepts it but then fails to sign up.

Tried the same on the PC, and it rejects the password because it doesn’t contain a non-alphanumeric. Add the non-alphanumeric to the password on the sign-up form on the phone, and it goes through ok. I’ll create a separate post for that bug.

At least the phone is logged in now (albeit with the wrong account).

Hey @southglos I’ve responded to your email but will update you here as well when we get this fixed. We’ve had some issues with oauth connections that the devs are aware of and working on, as well as the password reset in iOS causing a crash. I will investigate further. Let’s continue troubleshooting this in email to get you the password reset link as a temporary solution. Thanks!

1 Like