I'm locked out of the app

Mapillary asks me for my login again on my Android. I type in my login, but it still stays on the login screen. No way to get back into my account. Website works fine.

Since this seems less trivial then I expected here some more info. I am using the Mapillary app beta v. 3.95.
The reason why I am suddenly logged out, could come from none, one or both of these things that happened in between:

  1. there was an update of mapillary via the app store
  2. my phone warned me about few space left on the internal memory and recommended me to move some media and apps to the sd-card. Mapillary was moved.

Are you on WIFI ? I have the impression that it is harder on mobile data .

So I assume when you start the Mapillary app, that you get the screen with a Sign up and a Login button. You press the Login button.

Do you then get a choice for how you want to log in? Facebook, Google, Regular Email, OpenStreetMap, Log in with ArcGIS. Which of these do you use?

Do you get a error message when you try to log in? The error message may be small and only on the screen for a few seconds. For example, when I press Google to log in (I didn’t connect Mapillary to Google) I get a small message in the bottom of the screen “Could’t connect to Google” that is only visible for 2 seconds.

And of course you need a functioning internet connection. Try to open the Mapillary webpage from your mobile phone to confirm that you don’t happen to be outside of cell- or WiFi-cover.

To login to Wifi, I always go to the antenna. Afterwards, for the file transfer, the distance to the antenna is not so important.

Yes, I am on WIFI. And some more characters to make it more than 20.

My choice is Regular Email. When I first created my account there was no other option, and even now I would still choose not to interconnect my identities.
There is no error message. after tapping the Login button there is a message that reads: “Trying to log you in …”. Then, the screen shortly disappears, it’s really just a blink of the eye, then we are back to where to enter email and password.
I’s not the cell data, I am on wifi and internet works just fine.
I have tried to put a wrong username. Then I get a message: “Could not log in. Please check your Username/Password”
I also moved mapillary back to the internal memory. No difference.

There is another very strange thing: I still get notifications from the mapillary app that my blur requests are approved. Even though apparently I am not logged in!

It may help to clean the Mapillary app storage. You can try this:

  • Open the Android Settings app.
  • Go to Apps (this may be named differently on your phone, mine is a Samsung).
  • Tap the Mapillary app.
  • Tap Storage.
  • Tap Clear Data (and possibly Clear Cache, and maybe also Force Stop the app on the previous screen).

Now try to log in to the Mapillary app again.

No. Did not work. Then, I removed the app completely, reinstalled and still it did not work. Sorry, no more mapillary for me until this is fixed.
There are a couple of people reporting similar issues on github: https://github.com/mapillary/mapillary_issues/issues/2691
I think there should be a better in-house QC before the apps go out as betas.
It also should be possible to have the beta and non beta both installed, so it’s easier to fall back to the release when beta is broken.

That bug is specific about using an OSM account to log in, while you are using an email-login.

Did you follow my steps to clean all Mapillary data from your device? I am not sure if removing and reinstalling will actually clean the data.

I know from experience that it is very difficult to find all bugs using in-house QC. (If it wasn’t, then surely big commercial projects would be bug-free.)

Did you try installing an older version? Old versions can be downloaded from http://android-releases.mapillary.io/index.html

tried v 3.96-SNAPSHOT: same problem. tried v.3.89: says it’s a corrupted package. Which one should I try next?

Hi @vooni - just caught up with this thread. You said you’re able to log in on the web. Can I ask you to try to log in on your Android with another account? If you don’t have a friend with an account to borrow, please just create a new one on the web, and then test out whether you can log in with it on Android. (Asking this to figure out if your case is similar to an existing login-related case we’re investigating.)

Also, could we please continue troubleshooting via support@mapillary.com? It’s a better channel for issue-solving than the community forum. I’ll be looking forward to your email!

1 Like

Using OpenStreetCam meanwhile this issue persits, mapillary app developers really should look at how that app matured. Works even with screen switched off.


I found this thread because I have the same problems at the moment (verison 3.119). Cleaning the data and reinstalling the app didn’t help. I also logged in with the email method and got another screen for a part of a second and got back to the login screen immediatly.
I finally made a new account (“gzin2” instead of “gzin”) and that finally worked for me. What is wrong with the old account? I would like to use my old account again.
What was the final solution in this thread?


@gzin Did this start after you updated the app version to 3.119 or already before? I suppose you had created the first account with email signup. Did you create the second account also via email or some other method (like OSM)? Also, do you happen to have the app installed on an external SD card?

Hello Katrin,

what do you mean with “start”? I started contributing pictures years ago with my first account. I started the app after completly deinstalling and installing it again.

Yes, I created my first account with email signup, the second too.

I’ve Android 7.1.2 running on my phone and I have an expanded filesystem (one filesystem which includes the internal and the SD) and I do not have a possibility to select (because there is only one destination).

As I wrote above: I created a new account and logged in with it successfully. After that I logged off and got back to my old account and had the same problems again.



I’ve tried again and I’m still locked out with my main account. Now I’m also locked out with my second account! What’s wrong? What can I do to get it back working?


@gzin Sorry for not getting back to you! We have a fresh app version out - could you make sure to update to 3.121 and check if the problem persists? If yes, please write to us at support@mapillary.com