Mapillary_tools permission error (OSError: [Errno 13] Permission denied: '/data/IspraCascine/POT/.mapillary')

So what I did so far is:

  1. Pull the official ubuntu16.04 container from docker-hub
  2. inside install python2.7, pip (pip 19.1.1), git (2.7.4) and mapillary_tools (0.5.0), everything done as per the excellent guide (https://github.com/mapillary/mapillary_tools#custom-installation).

Everything seems to be installed and up and running, but then when I try a simple:
mapillary_tools process_and_upload --import_path /data/IspraCascine/POT --user_name momut1

i get:
File "/usr/local/bin/mapillary_tools", line 76, in <module> command.run(args) File "/usr/local/lib/python2.7/dist-packages/mapillary_tools/commands/process_and_upload.py", line 143, in run process_user_properties(**({k: v for k, v in vars_args.iteritems() File "/usr/local/lib/python2.7/dist-packages/mapillary_tools/process_user_properties.py", line 87, in process_user_properties user_properties) File "/usr/local/lib/python2.7/dist-packages/mapillary_tools/processing.py", line 788, in create_and_log_process_in_list verbose) File "/usr/local/lib/python2.7/dist-packages/mapillary_tools/processing.py", line 796, in create_and_log_process os.makedirs(log_root) File "/usr/lib/python2.7/os.py", line 150, in makedirs makedirs(head, mode) File "/usr/lib/python2.7/os.py", line 150, in makedirs makedirs(head, mode) File "/usr/lib/python2.7/os.py", line 157, in makedirs mkdir(name, mode) OSError: [Errno 13] Permission denied: '/data/IspraCascine/POT/.mapillary'

I’ve tried giving read, write, and execution permissions to all scripts in all folders of mapillary_tools with
find /usr/local/lib/python2.7/dist-packages/mapillary_tools/commands -type f -iname "*.py" -exec chmod +x {} \;

but I still get the same error. Does anyone have any experience with this issue? Is it because of the docker? Any help would be appreciated.

Thanks!

I use the tools (Debian 9) and have never seen the problem. (I run virtual though) I assume you have tried to;

mkdir /data/IspraCascine/POT/.mapillary

from the command prompt to test?

is the data device a linux writable as user filesystem? (thinking ntfs or vfat may have issues, or being mounted root)