Problem with installing Mapillary tools on Ubuntu

I tried to install the new simpler mapillary_tools on my Ubuntu (16.04).

All seemed to go pretty well with installing the dependencies but the actual installation of the tools gives errors.

Running

pip install git+https://github.com/mapillary/mapillary_tools

I get the following error message:

Command “/usr/bin/python -u -c “import setuptools, tokenize;file=’/tmp/pip-install-0PFBTn/Pillow/setup.py’;f=getattr(tokenize, ‘open’, open)(file);code=f.read().replace(’\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /tmp/pip-record-Go8xJS/install-record.txt --single-version-externally-managed --compile” failed with error code 1 in /tmp/pip-install-0PFBTn/Pillow/

For additional info:

When I ran

python get-pip.py

I got an error message

Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: ‘/usr/local/lib/python2.7/dist-packages/pip’
Consider using the --user option or check the permissions.

which I (at least thought) I tackled by running addind “–user” to the end of the command, hence running

python get-pip.py --user

which seemed to render success

Successfully installed pip-18.0 setuptools-40.0.0 wheel-0.31.1

Same issue happened with installing piexif and same fix worked(?).

pip install git+https://github.com/mapillary/Piexif --user

resulted into

Successfully installed piexif-1.0.13m

And that’s where my (supposed) luck ended with the error noted on the very top.

Now, I realized that putting the --user option added to the end didn’t seem to be the very right thing to do. So I went back and re-did all the steps. Only Pillow had not been installed and running that with

pip install --user Pillow

notes now that it too is installed.

But the error message installing mapillary_tools stays the same.

I also tried to do the installation in the virtualenv but to no avail. Same error

Command “/home/jaakko/env/bin/python3 -u -c “import setuptools, tokenize;file=’/tmp/pip-install-3zcmio41/Pillow/setup.py’;f=getattr(tokenize, ‘open’, open)(file);code=f.read().replace(’\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /tmp/pip-record-kt0oifpr/install-record.txt --single-version-externally-managed --compile --install-headers /home/jaakko/env/include/site/python3.5/Pillow” failed with error code 1 in /tmp/pip-install-3zcmio41/Pillow/

Any thoughts, anyone? Would be great to finally be able to upload the action cam photos that I’ve taken during the past two years.

Hey @jaakkoh thanks for reaching out-- I’ve received your email for this information as well. I’m waiting to hear back from my dev team for what they suggest. I will reach out to you once I hear from them. Thanks!

Considering a brand new ubuntu docker container I ran the following in order inside and everything works:

#set up proxy (if needed)

export http_proxy=http://10.168.209.73:8012

export https_proxy=http://10.168.209.73:8012

export ftp_proxy=http://10.168.209.73:8012

#prepare

apt-get update

apt-get install wget -y

apt-get install build-essential -y

#install python

cd ~

mkdir tmp

cd tmp

wget http://www.python.org/ftp/python/2.7.15/Python-2.7.15.tgz

tar zxvf Python-2.7.15.tgz

cd Python-2.7.15

./configure --prefix=$HOME/opt/python-2.7.15 --with-ensurepip=install

./configure --enable-optimizations

make

make install

#install zlib

wget http://www.zlib.net/zlib-1.2.11.tar.gz

tar -xvzf zlib-1.2.11.tar.gz

cd zlib-1.2.11

./configure --prefix=$HOME/tmp/zlib/zlib-1.2.11

make install

#install pip

apt install python-pip -y

pip install -U pip

#broken pip and then restart the container and it works ... go figure

# wget https://bootstrap.pypa.io/get-pip.py -O $HOME/tmp/pip/get-pip.py

# python $HOME/tmp/pip/get-pip.py

# pip install --user pipenv

# pip3 install --user pipenv

# echo "PATH=$HOME/.local/bin:$PATH" >> ~/.profile

# source ~/.profile

# whereis pip

#install mapillary uploader

apt-get update

apt-get install git-all -y

pip install git+https://github.com/mapillary/Piexif

pip install --upgrade git+https://github.com/mapillary/mapillary_tools

apt-get install ffmpeg -y