Pillow 2.9.0 will not install on Ubuntu 14.04 - Garmin Virb Elite images on hold

I set up a clean box with a Ubuntu 14.04 LTS.
I’ve installed the Tools from Github but the Pillow version can not be removed via pip - 2.3.0 comes installed and installing 2.9.0 or any other version will fail on this

Command /usr/bin/python -c “import setuptools, tokenize;file=’/tmp/pip_build_root/Pillow/setup.py’;exec(compile(getattr(tokenize, ‘open’, open)(file).read().replace(’\r\n’, ‘\n’), file, ‘exec’))” install --record /tmp/pip-wATHpH-record/install-record.txt --single-version-externally-managed --compile failed with error code 1 in /tmp/pip_build_root/Pillow
Storing debug log for failure in /root/.pip/pip.log

Trying to run with Pillow 2.3.0 gives me this
raceback (most recent call last):
File “geotag_from_gpx.py”, line 7, in
import pyexiv2
ImportError: No module named pyexiv2

So now I’ve got 600 images from my Garmin Virb Elite that I can’t geotag from the GPX file.

I had a similar thing with another script on ubuntu 16.04 and I installed the following packages:

exif
exiv2
python-exif
python-pyexiv2

I can’t remember all details and I’m not sure if all 4 packages are necessary, but this is what I installed and it works now.

@Stalfur did you get it to work?

/peter

@peter I did a re-install to Ubuntu 16 but had a HDD failure - that might have been the original problem. The images and videos sit tight for now.

@Stalfur, the problem seems to be that pyexiv2 was missing. This is most likely not related to PIL or PIL’s version. When you get ubuntu running, could you try installing the packages suggested by @de_vries using apt-get?

@pau Those installs did not get through - crashing on a similar note as pillow

Maybe you tried installing using pip? Using apt-get should work fine (in theory)

The good news is that most of the images on the Virb Elite ARE geotagged. It was only like the first 10-20 that weren’t due to GPS not kicking in…