Mapillary does not Work without Google Services


#1

Hi,

I recently purchased a Xiaomi Rednote 4 with stock MIUI, which I believe is an Android variant, but being in the PRC it doesn’t come with Google Play installed, and in fact all Google services are blocked.

When I install and open Mapillary, I get the following message:
“Mapillary won’t run without Google Play services, which are not supported by your device”.

I would like to ask why it is necessary for Google Play services to be installed to run Mapillary. Is there an option or workaround that would allow me to use and contribute to Mapillary without Google Services?


#2

Hey there! http://android-releases.mapillary.io/Mapillary_Android_current.apk and http://android-releases.mapillary.io/ for all releases. It’s also on the first Mapillary.com page. Let me know if you need anything else. Thanks!


#3

Thank you, Brenna, for your quick response.

I had already installed the app successfully using that first link but was receiving the aforementioned error message, and when I tried to log in using my OSM account it just gave me a blank screen.

However, good news; the OSM login now works and the app seems to be functional, despite giving me the same error message when I click ‘Capture’.

I will have to test it properly when I’m next outside with a GPS signal.


#4

Great, let me know how it goes-- if you keep running into issues shoot me an email at support@mapillary.com so I can compile this for the devs to look into :slight_smile: