Mapillary API: Setup with Postman

Hi everyone! I’m trying to setup Mapillary in Postman. Just wondering if anyone here has been successful in doing so? I’m struggling

Here’s my setup:

Which loads the auth screen successfully in my browser

However, hitting authorize gives

Without sharing sensitive info, here’s the app I’m using

Anyone have any ideas where I’m going wrong?

I’ll share the postman collection here with API endpoints once I get this auth issue sorted.

1 Like

I have managed to make requests from Postman to the API, altough I believe, as Mapillary’s OAuth flow is too different from a regular OAuth 2.0 one, Postman’s utilities for OAuth just don’t really work with it.

The error on the auth page you’re getting probably somehow relates to the authorization URL Postman’s generated, which, as by the OAuth standard, also including response type and redirect URI in the query params. Mapillary altough expects you to use the auth URL it supplies in the dev portal, which only contains your app id.

These kinds of oddities stretch throughout Mapillary’s entire OAuth flow and probably are the reason for your troubles.

I would reccomend for you to first just try getting the auth token and sending requests using that without setting any settings on your collection, just manually putting in your OAuth things into every request’s settings.

If you need any more help, I’d love to try; Hit me up with a direct message, if so.

Hey @Emilius123 , thanks for taking the time to reply.

just manually putting in your OAuth things into every request’s settings.

This is what I eventually resulted in doing, which works for local testing (which is enough for me, for now).

For this reading this not quite sure what I mean, here’s a sample request to the image search endpoint;

The ACCESS_TOKEN being your Mapillary Oauth apps’ client token (obtained from the Mapillary UI)…