GPS issue with Mapillary app only

My Mapillary mobility app has huge GPS issues. I have checked multiple times but at the same time GPS locate perfectly the position with several different apps, while Mapillary has a permanent Bad Gps Fix. I have tried to reinstall and update Mapillary, but it doesn’t get any better. An alternative option is using an external Garmin GPS to overwrite phone GPS, but I don’t think it will solve the issue.

1 Like


depends on the app what they tell you as perfect fix.
Not all apps are as exact as mapillary.
Also the GPS is not a real fixed signal, it is always added some variant. If that is to big, it is shown as not perfect in mapillary.

Depends on the fardware your mobile uses


The app I used in parallel is Google Mpas. Every time I tried, it gave me location without any issues, and it was very similar to one given with a Garmin GPS I use in parallel. Furthermore the path I tried to track is along a coastline, where no satellite issues should be arisen. I tried the survey of this track in different occasions. First I tried during summer, but the GPS malfunction was due to hot temperature, then I tried during spring, as i did last week. The system produced a strange path which went on the sea in many occasion, so I had to edit point by point, and it was a pity. How can I solve this?

Could that be related to these topics? Is the timing and order of the pictures correct?

My hypothesis: sometimes the GPS takes some time to converge from a bad to a good fix, and if the mapillary app messes up the timing during that phase (as in the bugs linked above), the pictures are located on the “converging” line, which is probably far from the correct line.

No, because I waited for a long time to have a stable GPS signal. Each time Mapillary stopped capturing, i stopped the operation and reload Mapillary. No GPS signal was retrieved by Mapillary. Google Maps, insted get a precise position. So, my GPS is working.

Mapillary app has strong requirement for HDOP. I do not remember it is 8 or 16 meters. You should check your phone’s signal. For example you could use OsmAnd, it will show precision as blue round. Google Maps cannot be used to be sure your signal is good.

I had the same issue on Samsung Note 3 Neo. It was not fixed until I changed phone.

1 Like

Because I don’t need ultra precision, is there a way to overlap GPS additional check (in comparison with google Map)? In alternative, is there a simple way to use external GPS as a GPS tracker overriding mobile GSP?