GoPro Fusion rendered photos not loading locations using Mapillary uploader


#1

I bought a GoPro Fusion to try out the built in GPS with 360 photo capture capabilities. Turns out the Mapillary Uploader doesn’t detect location coded into the photos, but Google Streetview does, as do other exif readers, like the one in the attached screen capture. Any ideas on why the Mapillary Uploader won’t read the location data that other apps can see and use?


#2

A guess: There are both the GPS tags on your screenshot but also one with lat and lng in one tag. Perhaps Mapillary is only looking for that. Would you mind posting an example of an image? If I am right, the issue should be fixable using exiftool and in that case I will make a command for you, so you can get on right away.


#3

Here’s an example rendered 360 image from GoPro Fusion Studio. Doesn’t seem that I can upload the photo, its about 12MB, I don’t get an error when uploading, but it doesn’t appear in my post. So, here is a link to the photo on Google Photos: https://photos.app.goo.gl/nhgam6wL2PYthjvu1


#4

It has all the gps tags, so my guess is now the dates, where several usual dates are not there. The fix is simple:

  1. Get exiftool from https://www.sno.phy.queensu.ca/~phil/exiftool/ - it is free/open source.
  2. In the folder where the images are, run the command exiftool '-alldates<${gpsdatetime}' *.jpg

You may have to enter the full path to exiftool or make sure it is in your PATH variable.
On Windows you may have to replace the ' with "
When you trust the tool enough, you can add the switch -overwrite_original to avoid the backup files it is making.

Please let me know if it works for you. That will teach everybody a bit more about how Mapillary works :slight_smile:


#5

Using exiftool with the command you provided definitely added exif tags to the images; however, Mapillary Uploader still doesn’t detect the correct information in the exif and throws the same error: “… image is missing EXIF data and needs to be placed on the map.”
BTW. the exiftool threw a “minor” warning when the command ran:
“Warning: [minor] Entries in IFD0 were out of sequence. Fixed. - IMAGE_0029.jpg”

Looks like the exiftool command added DateTimeOriginal and CreateDate tags, and adjusted the ModifyDate to match the GPSDateTime tag.

I’ve attached the exif data for the original and processed image.


#6

I suggest you write to hello@mapillary.com . I cannot find the error message in the public source code and I cannot figure out what is wrong. You have the same GPS tags in the composite group as one of my images.

Your image:

[Composite] GPS Altitude : 161.3 m Above Sea Level
[Composite] GPS Date/Time : 2018:02:18 161:18:00Z
[Composite] GPS Latitude : 161 deg 18’ 0.00" N
[Composite] GPS Longitude : 161 deg 18’ 0.00" W
[Composite] GPS Position : 161 deg 18’ 0.00" N, 161 deg 18’ 0.00" W
[Composite] Image Size : 5760x2880
[Composite] Megapixels : 16.6

My image:

[Composite] Aperture : 2.0
[Composite] GPS Altitude : 72 m Above Sea Level
[Composite] GPS Latitude : 56 deg 1’ 6.96" N
[Composite] GPS Longitude : 9 deg 9’ 32.90" E
[Composite] GPS Position : 56 deg 1’ 6.96" N, 9 deg 9’ 32.90" E
[Composite] Image Size : 4608x2592
[Composite] Megapixels : 11.9
[Composite] Shutter Speed : 1/11

There must be some detail that Mapillary does not like and I think only they can tell. But please post the respoonse if you get one!


#7

@rdelach we connected via support@mapillary.com. Sharing our GoPro Fusion status with the rest of the community:

We build beta support for the GoPro Fusion using our open-source Command Line Tools on Github. Always check for updates prior to an upload session. The GoPro Fusion Studio saves the stitched images with a unique metadata format that is not currently supported by our web uploader.

We can share a few additional notes and observations to help optimize your experience using this camera model.

  • Update GoPro Fusion camera software (firmware) to 01.60
  • Use a higher quality MicroSD card. We tested with SanDisk Extreme Class 30 (V30). See GoPro’s support article for MicroSD card considerations.
  • Stitch with GoPro Fusion Studio at least Version 1.1.1.400 (e67586b)

One note regarding limitations: After stitching in Fusion Studio the exported image will localize to 4 decimal places of precision which is precise to 11.132 meters at the equator. In the near term, you may need to adjust the image placement after upload or utilize an external GPS device. We are exploring methods that would eliminate this requirement.


#8

Please keep us updated on your experience with the fusion, namely stuff like:

  • links to examples of photos taken by it (on Mapillary)
  • how much of the whole sphere is used by Mapillary (e.g. how much of the own car is seen)
  • how often can it take a photo (1sec/photo? more?)
  • how long (hard, time spent, crashes) does it take from taking the photos from the two cards, to getting images ready for Mapillary (not counting any additional GPS tweaking)
  • photos photos photos

For €799 here, I’m considering buying one. If I’m investing effort on driving through unusual roads, I’d better take full advantage of that time and fuel. Having a GoPro6 to the front, a 3 to the back, and maybe a phone to the side, is too much effort, and won’t be 360.


#9

Sorry to bump an old thread, but has there been any improvements on the exif errors in the web uploader and GPS rounding?


#10

As far as I can tell, the GPS and exif data issues with the GoPro Fusion and Fusion Studio have all been resolved.
I have successfully used the Fusion to capture time-lapse photos (several hundred in one sequence), processed them in Fusion Studio (v1.3), and uploaded them using Mapillary web uploader. I have also been able to load those same photos into Google Maps using the Google StreetView app on Android.
The process is simple, no messing with external GPS, no need to run special scripts. It is all I had been hoping for when I bought the GoPro Fusion last February. It took GoPro around 10 months from product release to get it all working properly, but it does work. :slight_smile:


#11

They mentioned in the OSM-US slack channel they have a beta program with the GoPro camera that they can give anyone access to. But, with this new thing they are doing all you have to do is upload them. There computers stitch them together and post them. Witch would be a tremendous time saver.


#12

Really glad to hear that. I was trying to choose a 360 camera that would have a simpler workflow, not wanting to do all the gpx matching and correction. And with 360, doesn’t matter much if it has a compass or not. Quality is subpar, but then all consumer cameras are. Garmin 360, the only other serious contender with gps, is even worse with photos.
Would you have any recommendations for a (car) mount?
@Jaku103 so, similar to Panono? Would save some time (presuming they are using powerful rigs), but I’m guessing Mapillary won’t be among the upload options. Still not enough traction in the mainstream


#13

Regarding 360 camera, many can be connected to the phone and use the phones GPS. I use the Xiaomi Mi Sphere which can get an update from the phone every 1 seconds.


#14

True, but the camera’s module might be getting a better signal (outside the car), and has less latency I presume. Plus getting the phone’s GPS would require an active camera connection with the app, while the Fusion seems to be ok for standalone interval shooting, leaving my phone free for the other cameras