Do I have to allow scripts from an unauthenticated sources to upload images?

Is it normal to get the error message “This page is trying to load scripts from unauthenticated sources” when trying to upload images using https://www.mapillary.com/app/uploader using the Chromium browser? Also should I even be using the website to upload images that weren’t taken with the Mapillary app or do I need to use upload_with_authentication.py?

More detailed
I’m trying to upload some pictures I took with a Garmin Virb XE which I then cropped (using the GIMP in case it matters), sequenced using sequence_split.py, and interpolate directions using the python script. I then was tried to upload the images on https://www.mapillary.com/app/uploader because I wasn’t sure which upload script I should use and because the help page was just displaying “404” “72,552,379 photos and you missed them”. I frist tried uploading the images using Firefox but it got stuck at Uploading 0 / 137 and since I’m running no script I thought I would try using a different browser to see if that was the issue. So now I’m trying to use Chromium which is stuck at “Uploading 1 / 137” but it also is giving me the error “This page is trying to load scripts from unauthenticated sources”. So I would like to know if that’s normal and if it’s safe to load scripts from unauthenticated sources under these circumstances?

Hi @dhtg,

Sorry for the delayed reply here. Are you still experiencing this?

If so, can you send me some sample photos that you were trying to upload. The web uploader is designed to support photos from devices not supported by the app. As long as you have the correct Exif data, there shouldn’t be any issues so this is one for us to look into.

Thanks!