SOLVED : Mapillary Python CLI import tool: error: unrecognized arguments: --user_name

Processing now runs fine, several series have been uploaded, and are soon after visible in the OSM iD editor with the M. layer switched on. (Had, before uploading, looked at large thumbnails to weed out clearly blurred images, ‘undesirables’, and duplicates.)

One issue remains : regularly past day, either the USERname is ‘unrecognized’, or the email is ‘not valid’, even though they’re copy/pasted from a .txt document in Notepad++, and were correct earlier on.

User name and email are correct, as I’d first typed the entries in Notepad++, then copy/pasted when setting up; and email from Mapillary arrives at the address, occasionally includes the user name.

Causes are listed as:
1/ HTTPError: 500 Server Error: Internal Server Error for url|567515
2/ {“error”:{“message”:“Param email is not a valid email address”,“type”:“MLYApiException”,“code”:100,“fbtrace_id”:“AF5MPR…”}}

There is one confession : have earlier today authenticated another -more energy efficient- 2in1 for my processing and uploading, deleted two credentials from the previous ‘test machine’ - they were in C:\Users\username.config\mapillary\configs\ , going by dates, one was the CLI, the other the old DU.

Next, set up the ‘test machine’ for another u/n, e-m and p/w : could it be that removing user from one computer to another , then authenticating another user on that test machine - both on the same IP-address - upsets something?
Would it be a problem if that second machine remained connected to my address, as I have virtually unlimited upload volume?

Looking forward,

= = =
Edit 25aug : same ‘refusal’ this morning, after reboot.
= = =
Edit 26 Aug. : this time 'round the uploads worked, one finished early in the morning, the other in the midle of the afternoon.

Hence seems swapping machines wasn’t the cause, instead looks like -somehwere on the road between Mapillary and facebook- user authentication didn’t complete.

@eneerhut : you seem the most likely candidate to mention, as -in your capacity as Program Manager at Facebook Reality Labs- you’d be best placed to know whom to delegate this to?

Met als immer vriendelijke groet,

May not be worth opening another post for this : would the Python CLI tools show an alert in the Windows10 PowerShell if one were to upload photos which are already published, as the Web-uploader did, please?
Ask as there are quite a few pics missing from a sequence taken 5 June 2021 and uploaded few days later; there was the moove from API 3 to 4 , and pics not yet published are deemed lost, but approx. one-third of the series are on the map, hence interest.

I’ll open a task for us to look into this. There have been a few authentication issues reported recently with API v4, but I have not seen this one specifically.

As you said, I don’t think it’s related to authentication on two devices with the same IP. I’l report back here when i have more information.

I am not sure if this will be easy to implement, but I’ll look into it.

We’ll need to look into whether you have images in limbo that are not yet fully processed.

Limbo : past day or so re-uploaded that 5 June sequence, after reminded in another post that with change from V3 to V4 all pics that weren’t processed and published by around the anniversary of the merger are deemed lost.

Can now answer my question re. duplicates flagged : through an error uploaded from the wrong external HDD (the one with the full series, rather than the one with copies, where ‘definitely published pics’ had painstakingly been deleted; thus sent quite a pile of duplicates of already published photos, these were neither flagged at processing nor before upload commenced.

Please convey my grovelling apologies to the server, groaning under this extra load.

For the record : the authentication issue hasn’t (fingers crossed) reared its head the past ten days, and one computer uploading one user’s, the other the other user’s pics works fine. .

Marked solved on 29 Sep as the authentication issue has not reared its head again in over a month.

1 Like