Newbie Trying to process video on Mapillary tools 0.6.0

Hello, I am very new at Mapillary. I have been trying to make some sense of the commands. I dont quit sure what I am doing wrong but I keep on getting
error: argument tool: invalid choice: ‘video_process_and_upload’ (choose from ‘process’, ‘upload’, ‘process_and_upload’)
error: argument tool: invalid choice: ‘sample_video’ (choose from ‘process’, ‘upload’, ‘process_and_upload’)

I checked the help and in deed there is no commands relating video on the tools nor the advanced. however in the github files i see inside the mapillary)_tools folder there is a process_video.py and in the command folder there is a sample_video.py.
I forgot to mention I am using a mac and i used the python3 -m pip install --upgrade git+https://github.com/mapillary/mapillary_tools to install it on the terminal . I also have installed the ffmpeg.

Please can someone point me in the right direction bc I really dont know what am I missing. I thought maybe my tools installation was incomplete and I need to add missing files and folders but I am not sure how to get to the path directory of mapillarytool on my mac to check if all the files in the github are in there.
thank you

video_process_and_upload.py exists in the (online) github tools commands folder.

The github README.md does however say to use sample, process then upload commands OR video_process_and_upload, so you may wish to try this instead?

Thank you Bob I did try the sample first but I got invalid choice. I dont know maybe I am tying it wrong.I used several of the examples on the github web but I coundt even go pass the first line bc i got the error. tha did no t happend to proces images. I however wanted to ask you something, Why is the video_process_and_upload.py exist online but when installed I witht the git+https://github.com/mapillary/mapillary_tools it does not include those. I am lookig for tutorials but I cant fing many. I am guessing this is is just to simple for a tutorial and I am that newby that seems to not get it…

Here is what I wanted to do , I have a video taken with garmin virb. this camera give me a mp4. and gpx… I wanted to processs it with this code but i cant make it work not even a bit.

mapillary_tools sample_video --import_path “/Users/jd/Desktop/OUTPUTFOLDER”
–video_import_path “/Users/jd/Desktop/VIRBVIDEO.MP4”
–user_name “XXXXXXXXX”
–advanced
–geotag_source “gpx”
–geotag_source_path “/Users/jd/Desktop/VIRBVIDEO.gpx”
–video_sample_interval 0.3
–interpolate_directions \

I tried the first line

1 mapillary_tools sample_video --import_path “/Users/jd/Desktop/OUTPUTFOLDER”
2 mapillary_tools video_process --import_path “/Users/jd/Desktop/OUTPUTFOLDER”
3 mapillary_tools video_process_and_upload --video_import_path “/Users/jd/Desktop/OUTPUTFOLDER” .

I tried importh path also videoimporta path… cant figure it out =(
I am using a Mac if you wondering why the path fo the files seem different from windows

Ikeep getting

see -h for available tools and corresponding arguments, add --advanced to see additional advanced tools and/or arguments and --version to see version.

Mapillary import tool: error: argument tool: invalid choice: ‘video_process_and_upload’ (choose from ‘process’, ‘upload’, ‘process_and_upload’)

I haven’t run the tools locally for ages, but just did an install using the python3 virtual environment. (so it wont affect my production machine - linux)

site-packages/mapillary_tools/commands/ has about 20 files, one of which is video_process_and_upload.py

My first thought us that you have a broken or incomplete install so it’s worth trying that again. I would also try running the tools directly under python3 in case your system is defaulting to 2.

Your posted example appears to have single dashes before options too, the syntax is doubles.

Try sampling only first and later add more commands

mapillary_tools sample_video --import_path “d:\mapillary\images” --video_import_path “d:\mapillary\video” --video_sample_interval 1 --advanced

Adjust highlighted paths as per your requirements

import_path = where RESULTING (sampled) images are stored
video_import_path = where SOURCE video files are stored

Hello thanks Bob and GPS mapper it finally worked, Indeed it was all the code. for some reason it onlyl work for me the way gpsmapper mentioned in two steps and the firs steep in one line only

mapillary_tools sample_video --import_path “d:\mapillary\images” --video_import_path “d:\mapillary\video” --video_sample_interval 1 --advanced

It all had to be in one line of course for mac i looked like

mapillary_tools sample_video --video_import_path “FOLDERCONTAININGTHEVIDEO” --video_sample_interval 1 --advanced

Running this command first then using the new generating folder with the pictures and then process the images.

mapillary_tools process --advanced --import_path “mapillary_sampled_video_frames/VIRB0026”
–user_name “johndilinller”
–geotag_source “gpx”
–geotag_source_path “folder/026.gpx”
–use_gps_start_time
–overwrite_all_EXIF_tags

Thank you Bob and GPSmapper for the help. PROBLEM SOLVED

I Know is a bit off topic here but in order to offset the pictures with the video let say the vido syncs with the gps with 5 seconds difference how do i tell mapillary tools to increment or reduce the 5 seconds from the gpx file so this gets corrected?,
and the second thing does anybody knows if you have a gpx or a csv file with 10 records per second to only get one record per second or get the 10 records averaged in 1 record per second ., I need a gpx that only has one record per second .

anyway thanks for everything

Launching the tools with --advanced --help I think will show all the inputs plus the following

–offset_time OFFSET_TIME
time offset between the camera and the gps device, in seconds.

I’d suspect gpsbabel can reduce the data/time granularity using one of its filters, but have never tried myself.