Help setting up new mapillary_tools

Hi. I used the old mapillary_tools before, but I am currently stuck trying to set up the new mapillary_tools. Sometime ago I reset my Windows 10 64-bit, so I followed the instructions at https://github.com/mapillary/mapillary_tools from the start. Installed Python 2.7.15, updated pip to 18.0, installed git, installed Piexif, installed mapillary tools. Now I am at the path editing part, ‘C:\Python27’ and ‘C:\Python27\Scripts’ were already there in my system variables. What do I do here? I tried adding ‘C:\Python27\python.exe C:\Python27\Scripts\mapillary_tools’ in 1 line, and also separately, but I still can’t use mapillary_tools as command. Sorry, I am not really a command line kind of person, but what am I missing?

Thanks in advance!

I just re-read the installation steps, and I noticed that I did not install mapillary_tools by running the command in virtualenv or as sudo, as in the instructions, but I am unsure how to even do that… Does that apply to every OS? I run the mapillary_tools install normally and it says it has been installed successfully. But now I also realise I can’t locate that mapillary_tools/mapillary_tools/bin.

I know for sure that sudo does not apply to Windows. But I don’t use Windows so I cannot help you more.

I haven’t used the new Mapillary tools either, but I can try to help.

When editing your path, only C:\Python27 and C:\Python27\Scripts need to be put there. The path only takes directories, not executables like python.exe.

Did you copy bin\mapillary_tools into the \Python27\Scripts directory? After that, you should be able to run the tools with C:\python27\python.exe C:\python27\Scripts\mapillary_tools

1 Like

I just figured it out and my mapillary_tools is all set up. It seems windows users don’t need to deal with editing the path? I mean, I type python C:\Python27\Scripts\mapillary_tools instead of just python mapillary_tools, or even just mapillary_tools. I did end up installing virtualenv and running that one command in virtualenv, but I also installed mapillary_tools without virtualenv initially, so I don’t understand the necessity of that part.

Anyways, I am good, unless someone can tell me if there is a way to shorten that line I need to type? Thanks!

Shortening the command is exactly the reason for the path environment. You don’t need it (not on other OS’es either), but it is a convenience.

It is very possible that the Python installer already added the Python and Script directories to your path.

Ah, ok. And yes the Python directories are in my path after I installed Python.

But, is this convenience available in Windows in this case? The words in the README are kinda too cryptic for dummies like me… This part seems to be the key, but I can’t figure it out:

For as far as I can understand the README (which is cryptic I agree), the differences between Windows and Linux are:

  1. Under Windows you need to include the Python command. (Linux users can just run mapillary_tools.)
  2. Windows users may have to manually add the Python27\Scripts directory to their path. (I am not sure if this really is the case, or if the Python installer should do this automatically, but this is what the README seems to say.)

The path system works relatively identical on Windows and Linux.

I got it. On Windows, you have to change directory to C:\Python27\Scripts first, then you can use python mapillary_tools, assuming the directories are already inserted in the PATH. This having to cd is same as the old mapillary tools, I just realised… Case closed.

Anyway, thanks @pbb! I emailed mapillary support, they replied creating a ticket via Zendesk, but it seems they are so busy… Good thing I posted here as well.

Hey @raito, sorry for the delay on responding to your Zendesk – it’s only me handling Zendesk currently and I’ve just come back from a conference and am playing catch-up as quickly as I can :slight_smile: I will respond to you there as soon as possible.