Help for authenticating against Mapillary oauth2

I am developing an app where I need to have users to authenticate against Mapillary using oauth2. I hope you can help me figure out what I am doing wrong.
My problem is, that when I have redirected the user to Mapillary and the user has accepted, I always gets redirected to ?error=invalid_request&error_description=Wrong%20RedirectUri%20provided
I have tried redirect uris with localhost, 127.0.0.1 and on a real online domain, with the same result. All of them has been exact copies of the call back URI I provided when I generated the app keys.

The way I make the URL in Python is:

client_id = ‘Y0NtM3R4Zm52cTBOSUlrTFAwWFFFQTo5ODcxYTgzMTgzNzVhMTNi’
url = 'http://www.mapillary.com/connect?’+urllib.urlencode({‘client_id’:client_id, ‘response_type’:‘token’, ‘scope’:‘user:read’, ‘state’:‘return’, ‘redirect_uri’:‘http://zip.dk/mapillary/’})
which I use to send a Location header with a 302 temporary moved. This part seems to work fine.

An example of a URI I got from Chromes developer console is:
http://www.mapillary.com/connect?scope=user%3Aread&state=return&redirect_uri=http%3A%2F%2Flocalhost%3A7788%2Ftest.py&response_type=token&client_id=Y0NtM3R4Zm52cTBOSUlrTFAwWFFFQTo5ODcxYTgzMTgzNzVhMTNi

Now I hope there is something general with my URI I am doing wrong and I hope someone can help me - perhaps @katrin knows who :smile:

PS. I tried mailing hello@mapillary.com but i did not work - I submitted a separate issue on Github.

Hey @tryl - I think @peter or @gyllen can help you with this. If you submitted this on Github as well then more likely you’ll get a reply there. :smile:

How weird though that you couldn’t email to hello@mapillary.com! Did it just bounce back? We need to look into it!

Thanks. I have submitted an issue to https://github.com/mapillary/mapillary_issues/issues/2374 . The problems with the email is also submitted to Github, so hopefully someone will look at it.

Hello!
Did you received any answer about Wrong RedirectUti provided?
I am writing android application and I am using AppAuth to go throw Oauth and I have the same error.

This is a really old thread @zufir.

I’m guessing this was a previous bug, because the OAuth flow works flawlessly for me.

HI @trekview
Thank you for answer. Do you work with OAuth from android application or website?

Hi again.
I have found the reason for this eeror.
My bad. I forgot that Apps using Mapillary API settings has item Callback URL
This item should be equal to redirect_uri in authorization request.
Now it works for me.