GoPro Max timelapse images aren't fully in order

Example of it can be seen from starting from this image in the sequence : 249673367586575
I noticed that when, let’s say the GoPro takes images 1 2 3 4 5 6 7 8 (which are numbered in order), mapillary will show them in the sequence as 1 2 4 3 5 7 6 8, which causes a replay of a sequence to go back and forth

1 Like

Hi @TheWonderfulTartifle, thank you for reporting.

A few questions:

  1. Which tool did you use to upload and version of the tool? (Desktop uploader, CLI tools, or?)
  2. Could you please share any sequences as an example?

BR, Yaro

1 Like

I have used Mapillary uploader 3.2.3
That one for example : mHbPw91xr6QEIXTVaJnvF7

@nikola do you have any ideas/suggestions about this?

The images in a sequence are ordered by timestamp (when they were captured) and, in this case, there are some images that have the same timestamp (1681583358000 and then 1681583359000 etc.) - it looks like the time increments only by one second (there’s no milliseconds). Maybe there’s a setting on the camera to enable storing milliseconds in the timestamp or set the rate of capture at one image per second?

1 Like

Standard Exif info only allows storing whole seconds. Does Mapillary recognize XMP metadata?

I’ve changed to recording a maximum of 1 image per second to get around this problem, which is not optimal for many cases.

I think this is a bug we should fix on the Mapillary side (not just process by timestamp but also take filename or image order into account). However, I don’t see this issue replicating in Mapillary - @TheWonderfulTartifle can you provide a link where you are seeing it?

1 Like

On that image, and the image just after it : Mapillary There are some occurences after those images as well
If you’re unable to see it, here is a video of it : 2023-05-11 13-37-21.mp4 - Google Drive

Ah, I see, thank you. The problem is evident if you use the arrows at the top of the screen to step through the sequence. If you use the arrows at the bottom of the screen (which is what I was doing), it is displayed correctly - which is why I wasn’t seeing it at first. In any case its something we should fix on the Mapillary side I think. We’ll chat internally.

1 Like

Thanks, let me know if anything else is required and when the issue will be fixed :slight_smile:


This problem had been solved earlier in the open source mapillary tools: Issues · mapillary/mapillary_tools · GitHub

No XMP required, there are various “subsecond” properties defined in EXIF

(and I even had a script to create this subsec tag heuristically from such a sequence, but it was in the general mapillary github issues, which unfortunately had been deleted or moved: Subsecond Workflow
but apparently this had been reinvented in mapillary tools recently)

1 Like

As @enteq mentioned, this issue should be solved in fix: interpolate subsecs for images captured at the same seconds by ptpt · Pull Request #608 · mapillary/mapillary_tools · GitHub and released in Release v0.10.1 · mapillary/mapillary_tools · GitHub The fix for DU is coming too.


Are you sure it’s fixed ? There are still images that aren’t in order in what I uploaded, especially in videos

I have also had this at some point and I can summarize a situation like this:

Sometimes they’ll save an image, with the correct hour and seconds, but the minute amount won’t have gone +1

So you’ll get these timestamps in order of capture:

So Mapillary will place that image with the wrong timecode in a the ‘correct’ order that it thinks is right

This isn’t fixed in the desktop uploader yet, but should be fixed as of the next release. It’s only fixed in mapillary_tools at the moment.

1 Like

I’m the owner of a GoPro Hero7 Black which apparently doesn’t store subseconds data into the pictures; will this update affect me too?

I think you’re having the same issue as me, so it will very probably be included for you as well

Could you export the EXIF metadatas of one of the problematic sequences with

exiftool -r -ee -n -X -api LargeFileSupport=1 image_dir > images.xml

and share the xml with me for investigation?