Gear 360 (2017) No GPS data and timelapse captured as video

So I’ve just started mapping, and today I went out to try and get some captures with my Samsung Gear 360 (2017), and when I got back I realised that I couldn’t use any of it, as I used it’s timelapse function, which made it a video, and it had no GPS data. I tried using a modded version of the gear360 app but it just doesn’t work on my phone. Has anyone who uses this camera got any suggestions on what I could do? Could I extract each image from the timelapse and then add GPS data afterwards?

I have used my old apple phone to download the Gear360 app, and it works, sorta. I can use it to capture and export images, but I am not able to update its firmware, as its connected servers have been shut down by Samsung. Not that big of a deal. When I captured photos via the app, they were encoded with GPS information, and if I took a photo with the camera while it was connected to the phone, it would also have GPS data encoded. The problem is, when taking a time lapse or a video with the camera while it is connected to the app, it doesn’t record any GPS data, so that didn’t really help with anything. I think my next approach will be to do it as a standard .5 second time-lapse @ 4K, 10fps within the camera itself, convert it to a flat 360 video thingy, so it isn’t two fisheye views, using the Gear360 ActionDirector, do any post production in photoshop (blurring the bottom of the frame), then extract each one of those those frames and geotag it with GPS data from my phone, which I will use OsmAnd to capture, and then use something such as GeoSetter to add the GPS data to the images. It’s quite a long workflow, so I may consider getting something which will be much easier to use, such as the GoPro Max or an Insta360 Camera. If I can’t get this working, or its way too much of a hassle, I may consider using my GoPro Hero 5 Black for the time being until I purchase a newer 360 camera down the line, so that I can start getting captures asap!

Another Update:
For whatever reason, the piece of software which I was using to extract the frames downscales it horrendously, so I’m going to have to try and find something else to do it, or have to go frame by frame using VLCs screenshot tool, which I really don’t want to have to do :smiling_face_with_tear:

Third Update:
I have been able to use the switch control feature on my old iphone as what is basically an autoclicker. This means that I can just start this and it will continuously click the shutter for images in the app for me, solving every problem which I had. I will go and try it out either tomorrow on the weekend, and if it works well (enough), I will buy one of those thicker phone holders for my bike, and have my actual phone in the storage area, and my old phone up-front with the screen visible, so I can ensure that everything is working as it should, and so I can check the live feed to make sure nothing has happened such as the camera tilting to an angle or something along those lines. I’ll attempt to keep this post updated!

Have you tried exiftool?

exiftool -ee3 geaar360.mp4

and see if there is any GPS data in the output?

Thanks for responding! I checked the output and there is only 1 GPS coordinate within the timelapse. I may try taking one while moving in an outdoor space, as right now I’ve just been doing it inside, and maybe it needs more GPS data or something.

1 Like

I use the Gear 360(2017)
I do the stitching on PC using Gear 360 Action Director

two modes, video or individual photos spheres

Video mode + record GPS data separately on phone using APP GPS logger
You need to record the GPS data in a file called GPX
use this APP (other apps might work also)

Photosphere mode + imbedded GPS data in photos
then use software JPG2VID
to get MP4 video + GPX file