Fisheye distortion removal not working?

So, I remember there being a component of the web viewer that undistorted lens effects such as fisheye on gopro. It seemed to have worked on older photos.
However here for example


it doesn’t seem to be working.
Or is this the image being broken?

The nly thing I can think of is that the lens/image settings (EXIF) are not correct

I’d guess it’s default gopro - mapillary give them out, surely they know the exif of these

I was under the impression that the GoPro (and BlackVue) camera/lens ID (and thus correction) was set in the special Mapillary EXIF tag by (in my case) mapillary_tools arguments;

–device_make “Blackvue” --device_model “DR900S-1CH”
–geotag_source “gopro_videos”

My uploads (I think) get corrected some time after the original upload, more than a few weeks possibly.

There is a note about 3D geometry and correction in the tools README.md

This is of course the “video mode”, not those captured as single images. (This is also a deprecated method)

Your original image appears to not have any fisheye distortion (Click the … icon, “download image”). So perhaps the algorithm detects that it’s a GoPro and processes to undistort it. I would think that Mapillary would be able to detect what original view the camera was set to, but I’m not sure.

Somewhere (I cannot for the life of me find it again), Mapillary themselves listed the best settings for the GoPro with their platform. Specifically, the lens distortion should be set to ‘medium’, not ‘linear’. If that’s what yours is set to, it might be the cause of the issue.

Compare this image of mine: https://www.mapillary.com/app/?focus=photo&pKey=PSEKgxhZG9InjEEWitmhKA&tab=uploads&lat=38.41166426426429&lng=-82.59813696086832&z=17&x=0.5036146766551065&y=0.3032840246662793&zoom=0 When you download the original, you can see the telephone poles on the side are curved, compared to the Mapillary viewer where they’re straight.

EDIT to add: I use some pretty old Mapillary tools that don’t add any EXIF tags, so…

1 Like

thanks, that might be the reason.
I’ll comment on one of the images to see if the author can be persuaded to change the settings